diff mbox series

[02/11] pseudo: Remove 64bit time_t flags

Message ID 20221215084546.125368-2-raj.khem@gmail.com
State Accepted, archived
Commit e654cf03ba8f1f80ad75381f0ad666a282f6a27f
Headers show
Series [01/11] erofs-utils: Convert from off64_t to off_t | expand

Commit Message

Khem Raj Dec. 15, 2022, 8:45 a.m. UTC
pseudo traps syscalls and has intimate knowledge of them
and does not really depend on glibc interfaces to kernel

flags are added via TARGET_CC_ARCH therefore move the remove
operation from TARGET_CPPFLAGS to TARGET_CC_ARCH

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-devtools/pseudo/pseudo_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 8bb8993439..1a708066f7 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -22,7 +22,7 @@  PV = "1.9.0+git${SRCPV}"
 # aliased due to this e.g. open/open64 and it will complain about duplicate definitions
 # pseudo on 32bit systems is not much of use anyway and these features are not of much
 # use for it.
-TARGET_CPPFLAGS:remove = "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+TARGET_CC_ARCH:remove = "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_TIME_BITS=64"
 
 # error: use of undeclared identifier '_STAT_VER'
 COMPATIBLE_HOST:libc-musl = 'null'