diff mbox series

[24/24] gnupg: upgrade 2.3.7 -> 2.3.8

Message ID 20221213111118.149697-24-alex@linutronix.de
State Accepted, archived
Commit faf80d587849f181fc69b9a2924e8d44391c56c3
Headers show
Series [01/24] ptest-packagelists.inc: correctly assign fast and slow tests | expand

Commit Message

Alexander Kanavin Dec. 13, 2022, 11:11 a.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...-a-custom-value-for-the-location-of-.patch |  4 +--
 .../gnupg/gnupg/fix-ldap.patch                | 35 +++++++++++++++++++
 .../gnupg/gnupg/relocate.patch                | 18 +++++-----
 .../gnupg/{gnupg_2.3.7.bb => gnupg_2.3.8.bb}  |  3 +-
 4 files changed, 48 insertions(+), 12 deletions(-)
 create mode 100644 meta/recipes-support/gnupg/gnupg/fix-ldap.patch
 rename meta/recipes-support/gnupg/{gnupg_2.3.7.bb => gnupg_2.3.8.bb} (95%)
diff mbox series

Patch

diff --git a/meta/recipes-support/gnupg/gnupg/0001-configure.ac-use-a-custom-value-for-the-location-of-.patch b/meta/recipes-support/gnupg/gnupg/0001-configure.ac-use-a-custom-value-for-the-location-of-.patch
index c4ede9ea5e..eb2e47f035 100644
--- a/meta/recipes-support/gnupg/gnupg/0001-configure.ac-use-a-custom-value-for-the-location-of-.patch
+++ b/meta/recipes-support/gnupg/gnupg/0001-configure.ac-use-a-custom-value-for-the-location-of-.patch
@@ -1,4 +1,4 @@ 
-From 89b98553084fbefe1ef2c7cbff9e72cf43144c49 Mon Sep 17 00:00:00 2001
+From b0c42c8273c5fa1e31094567122be24ba28a965d Mon Sep 17 00:00:00 2001
 From: Alexander Kanavin <alex.kanavin@gmail.com>
 Date: Mon, 22 Jan 2018 18:00:21 +0200
 Subject: [PATCH] configure.ac: use a custom value for the location of
@@ -14,7 +14,7 @@  Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/configure.ac b/configure.ac
-index d86c60e..65c22b2 100644
+index b043386..dd839d0 100644
 --- a/configure.ac
 +++ b/configure.ac
 @@ -1955,7 +1955,7 @@ AC_DEFINE_UNQUOTED(GPGCONF_DISP_NAME, "GPGConf",
diff --git a/meta/recipes-support/gnupg/gnupg/fix-ldap.patch b/meta/recipes-support/gnupg/gnupg/fix-ldap.patch
new file mode 100644
index 0000000000..24299e16fb
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg/fix-ldap.patch
@@ -0,0 +1,35 @@ 
+From 7011286ce6e1fb56c2989fdafbd11b931c489faa Mon Sep 17 00:00:00 2001
+From: NIIBE Yutaka <gniibe@fsij.org>
+Date: Fri, 14 Oct 2022 09:58:41 +0900
+Subject: [PATCH] dirmngr: Fix build with no LDAP support.
+
+* dirmngr/server.c [USE_LDAP] (start_command_handler): Conditionalize.
+
+--
+
+GnuPG-bug-id: 6239
+Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
+Upstream-Status: Backport [https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=patch;h=7011286ce6e1fb56c2989fdafbd11b931c489faa]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ dirmngr/server.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/dirmngr/server.c b/dirmngr/server.c
+index 04ebfd317..98f354300 100644
+--- a/dirmngr/server.c
++++ b/dirmngr/server.c
+@@ -3137,8 +3137,10 @@ start_command_handler (assuan_fd_t fd, unsigned int session_id)
+                ctrl->refcount);
+   else
+     {
++#if USE_LDAP
+       ks_ldap_free_state (ctrl->ks_get_state);
+       ctrl->ks_get_state = NULL;
++#endif
+       release_ctrl_ocsp_certs (ctrl);
+       xfree (ctrl->server_local);
+       dirmngr_deinit_default_ctrl (ctrl);
+-- 
+2.11.0
+
diff --git a/meta/recipes-support/gnupg/gnupg/relocate.patch b/meta/recipes-support/gnupg/gnupg/relocate.patch
index 43999b8a6d..ca0e46141d 100644
--- a/meta/recipes-support/gnupg/gnupg/relocate.patch
+++ b/meta/recipes-support/gnupg/gnupg/relocate.patch
@@ -1,4 +1,4 @@ 
-From 89ae4f03307104689e1857d9857d452af6b35ac4 Mon Sep 17 00:00:00 2001
+From 7c6f9724f53ed2c5237dad4e3f4ec44091ac683d Mon Sep 17 00:00:00 2001
 From: Ross Burton <ross.burton@intel.com>
 Date: Wed, 19 Sep 2018 14:44:40 +0100
 Subject: [PATCH] Allow the environment to override where gnupg looks for its
@@ -14,10 +14,10 @@  Signed-off-by: Alexander Kanavin <alex@linutronix.de>
  1 file changed, 7 insertions(+), 7 deletions(-)
 
 diff --git a/common/homedir.c b/common/homedir.c
-index 260aeb2..1aeb08d 100644
+index 67bbde8..7f360ba 100644
 --- a/common/homedir.c
 +++ b/common/homedir.c
-@@ -1143,7 +1143,7 @@ gnupg_socketdir (void)
+@@ -1171,7 +1171,7 @@ gnupg_socketdir (void)
    if (!name)
      {
        unsigned int dummy;
@@ -26,7 +26,7 @@  index 260aeb2..1aeb08d 100644
        gpgrt_annotate_leaked_object (name);
      }
  
-@@ -1175,7 +1175,7 @@ gnupg_sysconfdir (void)
+@@ -1203,7 +1203,7 @@ gnupg_sysconfdir (void)
    if (dir)
      return dir;
    else
@@ -35,7 +35,7 @@  index 260aeb2..1aeb08d 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -1211,7 +1211,7 @@ gnupg_bindir (void)
+@@ -1239,7 +1239,7 @@ gnupg_bindir (void)
        return name;
      }
    else
@@ -44,7 +44,7 @@  index 260aeb2..1aeb08d 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -1238,7 +1238,7 @@ gnupg_libexecdir (void)
+@@ -1266,7 +1266,7 @@ gnupg_libexecdir (void)
        return name;
      }
    else
@@ -53,7 +53,7 @@  index 260aeb2..1aeb08d 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -1268,7 +1268,7 @@ gnupg_libdir (void)
+@@ -1296,7 +1296,7 @@ gnupg_libdir (void)
        return name;
      }
    else
@@ -62,7 +62,7 @@  index 260aeb2..1aeb08d 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -1299,7 +1299,7 @@ gnupg_datadir (void)
+@@ -1327,7 +1327,7 @@ gnupg_datadir (void)
        return name;
      }
    else
@@ -71,7 +71,7 @@  index 260aeb2..1aeb08d 100644
  #endif /*!HAVE_W32_SYSTEM*/
  }
  
-@@ -1331,7 +1331,7 @@ gnupg_localedir (void)
+@@ -1359,7 +1359,7 @@ gnupg_localedir (void)
        return name;
      }
    else
diff --git a/meta/recipes-support/gnupg/gnupg_2.3.7.bb b/meta/recipes-support/gnupg/gnupg_2.3.8.bb
similarity index 95%
rename from meta/recipes-support/gnupg/gnupg_2.3.7.bb
rename to meta/recipes-support/gnupg/gnupg_2.3.8.bb
index da2b1c4deb..aaa8d8fe99 100644
--- a/meta/recipes-support/gnupg/gnupg_2.3.7.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.3.8.bb
@@ -18,12 +18,13 @@  SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
            file://0002-use-pkgconfig-instead-of-npth-config.patch \
            file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
            file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
+           file://fix-ldap.patch \
            "
 SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
                                 file://relocate.patch"
 SRC_URI:append:class-nativesdk = " file://relocate.patch"
 
-SRC_URI[sha256sum] = "ee163a5fb9ec99ffc1b18e65faef8d086800c5713d15a672ab57d3799da83669"
+SRC_URI[sha256sum] = "540b7a40e57da261fb10ef521a282e0021532a80fd023e75fb71757e8a4969ed"
 
 EXTRA_OECONF = "--disable-ldap \
 		--disable-ccid-driver \