diff mbox series

[1/1] chrony: add pkgconfig class as pkg-config is explicitly searched for

Message ID 20221006040244.96372-1-fede@evolware.org
State New
Headers show
Series [1/1] chrony: add pkgconfig class as pkg-config is explicitly searched for | expand

Commit Message

Federico Pellegrin Oct. 6, 2022, 4:02 a.m. UTC
The configure script present in chrony will explicitly look for
pkg-config and without the pkgconfig class it will fail:

Checking for pkg-config : No

This then affects the possibility (via image features or bbappend)
to use features based on nettle/gnutls/nss which strictly require
pkgconfig to be present and working.

Signed-off-by: Federico Pellegrin <fede@evolware.org>
---
 meta-networking/recipes-support/chrony/chrony_4.3.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Ross Burton Oct. 6, 2022, 10:46 a.m. UTC | #1
This should go to openembedded-devel@, not -core@.

Also, there’s no need for a comment in the recipe explaining what the pkgconfig inherit is for, just put it on the same line as the other inherits.

Ross

> On 6 Oct 2022, at 05:02, Federico Pellegrin via lists.openembedded.org <fede=evolware.org@lists.openembedded.org> wrote:
> 
> The configure script present in chrony will explicitly look for
> pkg-config and without the pkgconfig class it will fail:
> 
> Checking for pkg-config : No
> 
> This then affects the possibility (via image features or bbappend)
> to use features based on nettle/gnutls/nss which strictly require
> pkgconfig to be present and working.
> 
> Signed-off-by: Federico Pellegrin <fede@evolware.org>
> ---
> meta-networking/recipes-support/chrony/chrony_4.3.bb | 3 +++
> 1 file changed, 3 insertions(+)
> 
> diff --git a/meta-networking/recipes-support/chrony/chrony_4.3.bb b/meta-networking/recipes-support/chrony/chrony_4.3.bb
> index 083d2cbc0..dfdb7864a 100644
> --- a/meta-networking/recipes-support/chrony/chrony_4.3.bb
> +++ b/meta-networking/recipes-support/chrony/chrony_4.3.bb
> @@ -47,6 +47,9 @@ DEPENDS = "pps-tools"
> #       chrony does not use GNU Autotools.
> inherit update-rc.d systemd
> 
> +# The configure scripts explicitly check for pkgconfig and needs it for gnutls/neetle/nss
> +inherit pkgconfig
> +
> # Add chronyd user if privdrop packageconfig is selected
> inherit ${@bb.utils.contains('PACKAGECONFIG', 'privdrop', 'useradd', '', d)}
> USERADD_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'privdrop', '${PN}', '', d)}"
> -- 
> 2.37.3
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#171479): https://lists.openembedded.org/g/openembedded-core/message/171479
> Mute This Topic: https://lists.openembedded.org/mt/94151504/6875888
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [ross.burton@arm.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-networking/recipes-support/chrony/chrony_4.3.bb b/meta-networking/recipes-support/chrony/chrony_4.3.bb
index 083d2cbc0..dfdb7864a 100644
--- a/meta-networking/recipes-support/chrony/chrony_4.3.bb
+++ b/meta-networking/recipes-support/chrony/chrony_4.3.bb
@@ -47,6 +47,9 @@  DEPENDS = "pps-tools"
 #       chrony does not use GNU Autotools.
 inherit update-rc.d systemd
 
+# The configure scripts explicitly check for pkgconfig and needs it for gnutls/neetle/nss
+inherit pkgconfig
+
 # Add chronyd user if privdrop packageconfig is selected
 inherit ${@bb.utils.contains('PACKAGECONFIG', 'privdrop', 'useradd', '', d)}
 USERADD_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'privdrop', '${PN}', '', d)}"