diff mbox series

psplash: add psplash-default in rdepends

Message ID 20221005171914.2889050-1-thomas.perrot@bootlin.com
State Accepted, archived
Commit 2a0928532b8303858980d6df6271669dbb69e224
Headers show
Series psplash: add psplash-default in rdepends | expand

Commit Message

Thomas Perrot Oct. 5, 2022, 5:19 p.m. UTC
From: Thomas Perrot <thomas.perrot@bootlin.com>

Otherwise when the installation of recommended packages is prevented
(NO_RECOMMENDATIONS = "1"), then splash screen will not be cast.

Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
---
 meta/recipes-core/psplash/psplash_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Michael Opdenacker Oct. 5, 2022, 5:25 p.m. UTC | #1
On 05.10.22 19:19, Thomas Perrot via lists.openembedded.org wrote:
> From: Thomas Perrot <thomas.perrot@bootlin.com>
>
> Otherwise when the installation of recommended packages is prevented
> (NO_RECOMMENDATIONS = "1"), then splash screen will not be cast.
>
> Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
> ---
>   meta/recipes-core/psplash/psplash_git.bb | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
> index edc0ac1d8961..9532ed1534a6 100644
> --- a/meta/recipes-core/psplash/psplash_git.bb
> +++ b/meta/recipes-core/psplash/psplash_git.bb
> @@ -58,7 +58,7 @@ python __anonymous() {
>           d.setVarFlag("ALTERNATIVE_TARGET_%s" % ep, 'psplash', '${bindir}/%s' % p)
>           d.appendVar("RDEPENDS:%s" % ep, " %s" % pn)
>           if p == "psplash-default":
> -            d.appendVar("RRECOMMENDS:%s" % pn, " %s" % ep)
> +            d.appendVar("RDEPENDS:%s" % pn, " %s" % ep)
>   }
>   
>   S = "${WORKDIR}/git"


Thanks Thomas. I confirm that the patch applies well now. You have a 
correct identity as a git commit author.
Thanks again
Michael.
diff mbox series

Patch

diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index edc0ac1d8961..9532ed1534a6 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -58,7 +58,7 @@  python __anonymous() {
         d.setVarFlag("ALTERNATIVE_TARGET_%s" % ep, 'psplash', '${bindir}/%s' % p)
         d.appendVar("RDEPENDS:%s" % ep, " %s" % pn)
         if p == "psplash-default":
-            d.appendVar("RRECOMMENDS:%s" % pn, " %s" % ep)
+            d.appendVar("RDEPENDS:%s" % pn, " %s" % ep)
 }
 
 S = "${WORKDIR}/git"