diff mbox series

psplash: add psplash-default in rdepends

Message ID 20221005145712.2528771-1-thomas.perrot@bootlin.com
State Accepted, archived
Commit 2a0928532b8303858980d6df6271669dbb69e224
Headers show
Series psplash: add psplash-default in rdepends | expand

Commit Message

Thomas Perrot Oct. 5, 2022, 2:57 p.m. UTC
Otherwise when the installation of recommended packages is prevented
(NO_RECOMMENDATIONS = "1"), then splash screen will not be cast.

Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
---
 meta/recipes-core/psplash/psplash_git.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Michael Opdenacker Oct. 5, 2022, 4:03 p.m. UTC | #1
Hello Thomas

Thanks for the patch!

On 05.10.22 16:57, Thomas Perrot via lists.openembedded.org wrote:
> Otherwise when the installation of recommended packages is prevented
> (NO_RECOMMENDATIONS = "1"), then splash screen will not be cast.
>
> Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>


There's a problem with the way you send your patches though. I used to 
have the same one.

If I apply your patch through "git am", the author of the commit is:
Thomas Perrot via lists.openembedded.org 
<thomas.perrot=bootlin.com@lists.openembedded.org>
instead of
Thomas Perrot <thomas.perrot@bootlin.com>

Because of this issue, the maintainer has to manually fix this field 
when accepting your patch. Worse, if he doesn't catch this, that's 
harder to fix afterwards.

You should be able to fix this by running:

git config --global sendemail.from "thomas.perrot@bootlin.com"

At least this worked for me from the same domain ;-) See 
https://www.openembedded.org/wiki/How_to_submit_a_patch_to_OpenEmbedded#Sending_using_git-send-email

Could you try to send an update? You could send it to me again through 
private-mail first.

Thanks in advance
Michael.
diff mbox series

Patch

diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index edc0ac1d8961..9532ed1534a6 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -58,7 +58,7 @@  python __anonymous() {
         d.setVarFlag("ALTERNATIVE_TARGET_%s" % ep, 'psplash', '${bindir}/%s' % p)
         d.appendVar("RDEPENDS:%s" % ep, " %s" % pn)
         if p == "psplash-default":
-            d.appendVar("RRECOMMENDS:%s" % pn, " %s" % ep)
+            d.appendVar("RDEPENDS:%s" % pn, " %s" % ep)
 }
 
 S = "${WORKDIR}/git"