diff mbox series

[v2] binutils: handle symlink files for gprofng

Message ID 20220919044803.15248-1-kai.kang@windriver.com
State Accepted, archived
Commit 35bec42c4023a00a0a3639935633051ce9c1c0ba
Headers show
Series [v2] binutils: handle symlink files for gprofng | expand

Commit Message

Kai Sept. 19, 2022, 4:48 a.m. UTC
From: Kai Kang <kai.kang@windriver.com>

It provides gprofng by binutils 2.39 for x86, x86_64 and aarch64
according to configure.ac:

https://sourceware.org/git/?p=binutils-gdb.git;a=blob;f=configure.ac;h=a5555a9c91b42214afc46a0ab8b629e4c6fedcc0;hb=HEAD#l401

Add them to USE_ALTERNATIVES_FOR the same as others to handle symlink
files via update-alternative mechanism.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 meta/recipes-devtools/binutils/binutils.inc | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Alexandre Belloni Sept. 21, 2022, 12:09 p.m. UTC | #1
Hello,

On 19/09/2022 12:48:03+0800, kai wrote:
> From: Kai Kang <kai.kang@windriver.com>
> 
> It provides gprofng by binutils 2.39 for x86, x86_64 and aarch64
> according to configure.ac:
> 
> https://sourceware.org/git/?p=binutils-gdb.git;a=blob;f=configure.ac;h=a5555a9c91b42214afc46a0ab8b629e4c6fedcc0;hb=HEAD#l401
> 
> Add them to USE_ALTERNATIVES_FOR the same as others to handle symlink
> files via update-alternative mechanism.
> 

We get the following warnings on musl:
https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5882/steps/11/logs/warnings


> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> ---
>  meta/recipes-devtools/binutils/binutils.inc | 14 ++++++++++++++
>  1 file changed, 14 insertions(+)
> 
> diff --git a/meta/recipes-devtools/binutils/binutils.inc b/meta/recipes-devtools/binutils/binutils.inc
> index 789c8bec21..0f56fb3e2e 100644
> --- a/meta/recipes-devtools/binutils/binutils.inc
> +++ b/meta/recipes-devtools/binutils/binutils.inc
> @@ -36,6 +36,19 @@ FILES:${PN}-dev = " \
>  # Rather than duplicating multiple entries for these, make one
>  # list and reuse it.
>  
> +GPROFNGS = " \
> +	gp-archive \
> +	gp-collect-app \
> +	gp-display-html \
> +	gp-display-src \
> +	gp-display-text \
> +	gprofng \
> +"
> +GPROFNG_ALTS ?= ""
> +GPROFNG_ALTS:x86 = "${GPROFNGS}"
> +GPROFNG_ALTS:x86-64 = "${GPROFNGS}"
> +GPROFNG_ALTS:aarch64 = "${GPROFNGS}"
> +
>  LDGOLD_ALTS ?= "ld.gold dwp"
>  LDGOLD_ALTS:riscv64 = ""
>  LDGOLD_ALTS:riscv32 = ""
> @@ -48,6 +61,7 @@ USE_ALTERNATIVES_FOR = " \
>  	c++filt \
>  	elfedit \
>  	gprof \
> +	${GPROFNG_ALTS} \
>  	ld \
>  	ld.bfd \
>  	${LDGOLD_ALTS} \
> -- 
> 2.17.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#170855): https://lists.openembedded.org/g/openembedded-core/message/170855
> Mute This Topic: https://lists.openembedded.org/mt/93775511/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/binutils/binutils.inc b/meta/recipes-devtools/binutils/binutils.inc
index 789c8bec21..0f56fb3e2e 100644
--- a/meta/recipes-devtools/binutils/binutils.inc
+++ b/meta/recipes-devtools/binutils/binutils.inc
@@ -36,6 +36,19 @@  FILES:${PN}-dev = " \
 # Rather than duplicating multiple entries for these, make one
 # list and reuse it.
 
+GPROFNGS = " \
+	gp-archive \
+	gp-collect-app \
+	gp-display-html \
+	gp-display-src \
+	gp-display-text \
+	gprofng \
+"
+GPROFNG_ALTS ?= ""
+GPROFNG_ALTS:x86 = "${GPROFNGS}"
+GPROFNG_ALTS:x86-64 = "${GPROFNGS}"
+GPROFNG_ALTS:aarch64 = "${GPROFNGS}"
+
 LDGOLD_ALTS ?= "ld.gold dwp"
 LDGOLD_ALTS:riscv64 = ""
 LDGOLD_ALTS:riscv32 = ""
@@ -48,6 +61,7 @@  USE_ALTERNATIVES_FOR = " \
 	c++filt \
 	elfedit \
 	gprof \
+	${GPROFNG_ALTS} \
 	ld \
 	ld.bfd \
 	${LDGOLD_ALTS} \