diff mbox series

meta/files/layers.schema.json: drop the layers property

Message ID 20220901183749.475176-1-alex@linutronix.de
State Accepted, archived
Commit 64a774de0e154ef81f20853fec903b17d9985a72
Headers show
Series meta/files/layers.schema.json: drop the layers property | expand

Commit Message

Alexander Kanavin Sept. 1, 2022, 6:37 p.m. UTC
This is a leftover from one of the RFC iterations, where
the property contained available machines, distros and templates.
As all of those were dropped from the final version, there is no
reason to list the layers either anymore.

Normally this would be a backwards incompatible change, but as
the layer setup itself was just merged, I think we can do a quick
fixup :-)

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/files/layers.example.json | 24 ------------------------
 meta/files/layers.schema.json  | 15 ---------------
 meta/lib/bblayers/makesetup.py |  3 +--
 scripts/oe-setup-layers        | 10 ----------
 4 files changed, 1 insertion(+), 51 deletions(-)
diff mbox series

Patch

diff --git a/meta/files/layers.example.json b/meta/files/layers.example.json
index 3772404ec9..0a6a6a7b48 100644
--- a/meta/files/layers.example.json
+++ b/meta/files/layers.example.json
@@ -12,11 +12,6 @@ 
                 },
                 "rev": "05b25605fb8b2399e4706d7323828676bf0da0b5"
             },
-            "layers": {
-                "meta-alex": {
-                    "subpath": ""
-                }
-            },
             "path": "meta-alex"
         },
         "meta-intel": {
@@ -30,11 +25,6 @@ 
                 },
                 "rev": "0a96edae609a3f48befac36af82cf1eed6786b4a"
             },
-            "layers": {
-                "meta-intel": {
-                    "subpath": ""
-                }
-            },
             "path": "meta-intel"
         },
         "poky": {
@@ -51,20 +41,6 @@ 
                 },
                 "rev": "9dda719b2a4727a4d43a6ab8d9e23f8ca68790ec"
             },
-            "layers": {
-                "meta": {
-                    "subpath": "meta"
-                },
-                "meta-poky": {
-                    "subpath": "meta-poky"
-                },
-                "meta-selftest": {
-                    "subpath": "meta-selftest"
-                },
-                "meta-yocto-bsp": {
-                    "subpath": "meta-yocto-bsp"
-                }
-            },
             "path": "poky"
         }
     },
diff --git a/meta/files/layers.schema.json b/meta/files/layers.schema.json
index cd4ddd3dcd..659ee8da49 100644
--- a/meta/files/layers.schema.json
+++ b/meta/files/layers.schema.json
@@ -29,21 +29,6 @@ 
                         "description": "Whether the directory with the layer source also contains this json description. Tools may want to skip the checkout of the source then.",
                         "type": "boolean"
                     },
-                    "layers": {
-                        "description": "The dict of layers to be used from this upstream source",
-                        "type": "object",
-                        "patternProperties": { ".*" : {
-                            "description": "A layer from the upstream source",
-                            "type": "object",
-                            "additionalProperties": false,
-                            "properties": {
-                                "subpath": {
-                                    "description": "The subpath (relative to the source root) for this layer. Omit if the source root is the layer path",
-                                    "type": "string"
-                                }
-                            }
-                        }}
-                    },
                     "git-remote": {
                                 "description": "A remote git source from which to fetch",
                                 "type": "object",
diff --git a/meta/lib/bblayers/makesetup.py b/meta/lib/bblayers/makesetup.py
index bef6da0ea8..22f89d81a4 100644
--- a/meta/lib/bblayers/makesetup.py
+++ b/meta/lib/bblayers/makesetup.py
@@ -64,13 +64,12 @@  class MakeSetupPlugin(LayerPlugin):
                 return
             repo_path = self._get_repo_path(l_path)
             if repo_path not in repos.keys():
-                repos[repo_path] = {'path':os.path.basename(repo_path),'layers':{},'git-remote':{'rev':l_rev, 'branch':l_branch, 'remotes':self._get_remotes(repo_path), 'describe':self._get_describe(repo_path)}}
+                repos[repo_path] = {'path':os.path.basename(repo_path),'git-remote':{'rev':l_rev, 'branch':l_branch, 'remotes':self._get_remotes(repo_path), 'describe':self._get_describe(repo_path)}}
                 if repo_path == destdir_repo:
                     repos[repo_path]['contains_this_file'] = True
                 if not repos[repo_path]['git-remote']['remotes'] and not repos[repo_path]['contains_this_file']:
                     logger.error("Layer repository in {path} does not have any remotes configured. Please add at least one with 'git remote add'.".format(path=repo_path))
                     return
-            repos[repo_path]['layers'][l_name] = {'subpath':l_path.replace(repo_path,'')[1:]}
 
         top_path = os.path.commonpath([os.path.dirname(r) for r in repos.keys()])
 
diff --git a/scripts/oe-setup-layers b/scripts/oe-setup-layers
index cbd2efb5c7..6ecaffed75 100755
--- a/scripts/oe-setup-layers
+++ b/scripts/oe-setup-layers
@@ -18,20 +18,10 @@  import subprocess
 
 def _do_checkout(args, json):
     layers = json['sources']
-    buildconfs = []
-    oecorepath = ""
     for l_name in layers:
         l_data = layers[l_name]
         layerdir = os.path.abspath(os.path.join(args['destdir'], l_data['path']))
 
-        for ll_name in l_data['layers']:
-            if ll_name == 'meta':
-                oecorepath = layerdir
-            ll_data = l_data['layers'][ll_name]
-            if 'buildconfigs' in ll_data:
-                for c in ll_data['buildconfigs']:
-                    buildconfs.append(os.path.join(layerdir, ll_data['subpath'], c))
-
         if 'contains_this_file' in l_data.keys():
             force_arg = 'force_bootstraplayer_checkout'
             if not args[force_arg]: