diff mbox series

[1/2] packagegroup-rust-cross-canadian: add native compiler environment

Message ID 20220823085636.30868-1-peter@berginkonsult.se
State Accepted, archived
Commit 1de29eb5ec091427560e1f0b6b16c91a3a994835
Headers show
Series [1/2] packagegroup-rust-cross-canadian: add native compiler environment | expand

Commit Message

Peter Bergin Aug. 23, 2022, 8:56 a.m. UTC
When building rust crates it is quite common to have a build script [1]
that is compiled for the host machine and then used during build for target.
Currently when adding packagegroup-rust-cross-canadian this does not work
without having the native compiler and linker added to the SDK.
Add those packages to the packagegroup to make it easier to handle.

The reason for having glibc-dev and libgcc-dev is to have version match
with the used tools. Otherwise it will work on hosts that have compatible
gcc and glibc versions but not on all.

[1] https://doc.rust-lang.org/cargo/reference/build-scripts.html

Signed-off-by: Peter Bergin <peter@berginkonsult.se>
---
 .../packagegroups/packagegroup-rust-cross-canadian.bb         | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Otavio Salvador Aug. 23, 2022, 11:49 a.m. UTC | #1
Em ter., 23 de ago. de 2022 às 05:57, Peter Bergin <peter@berginkonsult.se>
escreveu:

> When building rust crates it is quite common to have a build script [1]
> that is compiled for the host machine and then used during build for
> target.
> Currently when adding packagegroup-rust-cross-canadian this does not work
> without having the native compiler and linker added to the SDK.
> Add those packages to the packagegroup to make it easier to handle.
>
> The reason for having glibc-dev and libgcc-dev is to have version match
> with the used tools. Otherwise it will work on hosts that have compatible
> gcc and glibc versions but not on all.
>

This should be in a comment inside the packagegroup.


> [1] https://doc.rust-lang.org/cargo/reference/build-scripts.html
>
> Signed-off-by: Peter Bergin <peter@berginkonsult.se>
>
diff mbox series

Patch

diff --git a/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb b/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb
index 42f85f0eb38..bb10a2d34f2 100644
--- a/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-rust-cross-canadian.bb
@@ -9,6 +9,10 @@  RUST="rust-cross-canadian-${TRANSLATED_TARGET_ARCH}"
 
 RDEPENDS:${PN} = " \
     ${@all_multilib_tune_values(d, 'RUST')} \
+    nativesdk-binutils \
+    nativesdk-gcc \
+    nativesdk-glibc-dev \
+    nativesdk-libgcc-dev \
     nativesdk-rust \
     nativesdk-cargo \
     nativesdk-rust-tools-clippy \