diff mbox series

python3-hypothesis: revert back to 6.46.11

Message ID 20220818031305.53389-1-Qi.Chen@windriver.com
State Accepted, archived
Commit 37c5b171d7de25b131e77b80d37f8481308bd6fe
Headers show
Series python3-hypothesis: revert back to 6.46.11 | expand

Commit Message

ChenQi Aug. 18, 2022, 3:13 a.m. UTC
This package was broken since it was upgraded to 6.48, because
it started using 'exceptiongroup' since then, which is missing
in any meta layer. On target, when importing hypothesis, we meet
the following error:

  Traceback (most recent call last):
  File "/usr/lib64/python3.10/site-packages/hypothesis/internal/compat.py", line 18, in <module>
  BaseExceptionGroup = BaseExceptionGroup
  NameError: name 'BaseExceptionGroup' is not defined. Did you mean: 'BaseException'?
  ModuleNotFoundError: No module named 'exceptiongroup'

The related codes as below:
try:
    BaseExceptionGroup = BaseExceptionGroup
    ExceptionGroup = ExceptionGroup  # pragma: no cover
except NameError:
    from exceptiongroup import (
        BaseExceptionGroup as BaseExceptionGroup,
        ExceptionGroup as ExceptionGroup,
    )

We can see that it tries to use ExceptionGroup and falls back to
use an import from exceptiongroup module.

Looking at the https://github.com/agronholm/exceptiongroup, it says:
"""
This is a backport of the BaseExceptionGroup and ExceptionGroup classes from Python 3.11.
"""

So instead of adding a new recipe for exception group, it might be
better to revert to a working version and wait for python 3.11 to release.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 ...thon3-hypothesis_6.54.1.bb => python3-hypothesis_6.46.11.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-hypothesis_6.54.1.bb => python3-hypothesis_6.46.11.bb} (91%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb b/meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
similarity index 91%
rename from meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb
rename to meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
index afcd5e64ef..1d9772d4ff 100644
--- a/meta/recipes-devtools/python/python3-hypothesis_6.54.1.bb
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
@@ -13,7 +13,7 @@  SRC_URI += " \
     file://test_rle.py \
     "
 
-SRC_URI[sha256sum] = "de63c34309181875e71d0f5d1c1051c9320a1fe0517ea6733af8cedf818191f4"
+SRC_URI[sha256sum] = "f5c1cf61b24b094355577a6b8fbbb8eb54c1b0216fbc0519af97c46bddf43c42"
 
 RDEPENDS:${PN} += " \
     python3-attrs \