diff mbox series

[8/8] skeleton/service: Ensure debug path handling works as intended

Message ID 20220816205746.1672987-8-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 299abc1d69db13924f02d922139051126f19b306
Headers show
Series [1/8] package: Switch debug source handling to use prefix map | expand

Commit Message

Richard Purdie Aug. 16, 2022, 8:57 p.m. UTC
DEBUG_PREFIX_MAP uses ${S} but that wasn't set correctly for this
recipe meaning cwd during the build (WORKDIR) was encoded into the
binary leading to buildpath warnings in debug symbols. Set S correctly
to avoid this issue.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta-skeleton/recipes-skeleton/service/service_0.1.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta-skeleton/recipes-skeleton/service/service_0.1.bb b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
index d1d8c5f3656..912f6b0f611 100644
--- a/meta-skeleton/recipes-skeleton/service/service_0.1.bb
+++ b/meta-skeleton/recipes-skeleton/service/service_0.1.bb
@@ -9,6 +9,8 @@  SRC_URI = "file://skeleton \
 	   file://COPYRIGHT \
 	   "
 
+S = "${WORKDIR}"
+
 do_compile () {
 	${CC} ${CFLAGS} ${LDFLAGS} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
 }