diff mbox series

[3/7] rpm: Remove -Wimplicit-function-declaration warnings

Message ID 20220816165857.2342796-3-raj.khem@gmail.com
State Accepted, archived
Commit 9f2dbfc51ef2faf1b6154856adb69ca9f764573b
Headers show
Series [1/7] boost: Compile out stdlib unary/binary_functions for c++11 and newer | expand

Commit Message

Khem Raj Aug. 16, 2022, 4:58 p.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...ude-lib-rpmchroot.h-for-rpmChrootOut.patch | 26 +++++++++++++++++++
 meta/recipes-devtools/rpm/rpm_4.17.1.bb       |  1 +
 2 files changed, 27 insertions(+)
 create mode 100644 meta/recipes-devtools/rpm/files/0001-rpmscript-Include-lib-rpmchroot.h-for-rpmChrootOut.patch
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rpm/files/0001-rpmscript-Include-lib-rpmchroot.h-for-rpmChrootOut.patch b/meta/recipes-devtools/rpm/files/0001-rpmscript-Include-lib-rpmchroot.h-for-rpmChrootOut.patch
new file mode 100644
index 00000000000..2e0665853bf
--- /dev/null
+++ b/meta/recipes-devtools/rpm/files/0001-rpmscript-Include-lib-rpmchroot.h-for-rpmChrootOut.patch
@@ -0,0 +1,26 @@ 
+From fee6dd39e7223700cc4f7e073924b18409b645b6 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 15 Aug 2022 22:45:23 -0700
+Subject: [PATCH] rpmscript: Include lib/rpmchroot.h for rpmChrootOut()
+
+This fixes implicit function declarations warning
+
+Upstream-Status: Submitted [https://github.com/rpm-software-management/rpm/pull/2152]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ lib/rpmscript.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/rpmscript.c b/lib/rpmscript.c
+index 3e3a0027a..6d6d4c507 100644
+--- a/lib/rpmscript.c
++++ b/lib/rpmscript.c
+@@ -17,7 +17,7 @@
+ #include "rpmio/rpmio_internal.h"
+ 
+ #include "lib/rpmplugins.h"     /* rpm plugins hooks */
+-
++#include "lib/rpmchroot.h" /* rpmChrootOut */
+ #include "debug.h"
+ 
+ struct scriptNextFileFunc_s {
diff --git a/meta/recipes-devtools/rpm/rpm_4.17.1.bb b/meta/recipes-devtools/rpm/rpm_4.17.1.bb
index 9b6446f265f..66955ad98ca 100644
--- a/meta/recipes-devtools/rpm/rpm_4.17.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.17.1.bb
@@ -40,6 +40,7 @@  SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.17.x;protoc
            file://0001-docs-do-not-build-manpages-requires-pandoc.patch \
            file://0001-build-pack.c-do-not-insert-payloadflags-into-.rpm-me.patch \
            file://0001-configure.ac-add-linux-gnux32-variant-to-triplet-han.patch \
+           file://0001-rpmscript-Include-lib-rpmchroot.h-for-rpmChrootOut.patch \
            "
 
 PE = "1"