diff mbox series

perf: Add packageconfig for libbfd support and use disabled as default

Message ID 20220815034846.3459068-1-raj.khem@gmail.com
State Accepted, archived
Commit 119b37cd59163970476644183ed509a2d2ea6acd
Headers show
Series perf: Add packageconfig for libbfd support and use disabled as default | expand

Commit Message

Khem Raj Aug. 15, 2022, 3:48 a.m. UTC
Disable it by default, libbfd changes with binutils major releases and
sometimes it creates a dependency to fix it. See [1]

This will help building with binutils 2.39

[1] https://lore.kernel.org/lkml/20210910225756.729087-1-irogers@google.com/T/

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/perf/perf.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Bruce Ashfield Aug. 15, 2022, 12:36 p.m. UTC | #1
On Sun, Aug 14, 2022 at 11:48 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> Disable it by default, libbfd changes with binutils major releases and
> sometimes it creates a dependency to fix it. See [1]
>
> This will help building with binutils 2.39

Ack'd. The change is good with me.

I have linux-yocto changes for the new binutils, but this will help
other kernels until they update.

Bruce

>
> [1] https://lore.kernel.org/lkml/20210910225756.729087-1-irogers@google.com/T/
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Bruce Ashfield <bruce.ashfield@gmail.com>
> ---
>  meta/recipes-kernel/perf/perf.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
> index 95b4362958b..9f7c300a40e 100644
> --- a/meta/recipes-kernel/perf/perf.bb
> +++ b/meta/recipes-kernel/perf/perf.bb
> @@ -20,6 +20,7 @@ PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
>  PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
>  PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
>  PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
> +PACKAGECONFIG[bfd] = ",NO_LIBBFD=1"
>  PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
>  PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
>  # libaudit support would need scripting to be enabled
> --
> 2.37.2
>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 95b4362958b..9f7c300a40e 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -20,6 +20,7 @@  PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
 PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
 PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
 PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
+PACKAGECONFIG[bfd] = ",NO_LIBBFD=1"
 PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
 PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
 # libaudit support would need scripting to be enabled