diff mbox series

[3/4] testexport: Fix to work as an image class

Message ID 20220812104514.825820-3-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit ed4238487c81b3580e83c257b50745a832a6e717
Headers show
Series [1/4] selftest/runtime_test/incompatible_lic: Use IMAGE_CLASSES for testimage | expand

Commit Message

Richard Purdie Aug. 12, 2022, 10:45 a.m. UTC
The class is mainly an image based class but one recipe does need to look
at values shared with the class and isn't an image. Move this to a conf
file instead, avoiding the need to pollute all recipes globally.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/classes/testexport.bbclass              | 5 ++---
 meta/conf/testexport.conf                    | 3 +++
 meta/recipes-core/meta/testexport-tarball.bb | 2 +-
 3 files changed, 6 insertions(+), 4 deletions(-)
 create mode 100644 meta/conf/testexport.conf
diff mbox series

Patch

diff --git a/meta/classes/testexport.bbclass b/meta/classes/testexport.bbclass
index 01656455e84..98468c96fd1 100644
--- a/meta/classes/testexport.bbclass
+++ b/meta/classes/testexport.bbclass
@@ -23,10 +23,9 @@  TEST_TARGET ?= "simpleremote"
 TEST_TARGET_IP ?= ""
 TEST_SERVER_IP ?= ""
 
-TEST_EXPORT_SDK_PACKAGES ?= ""
+require conf/testexport.conf
+
 TEST_EXPORT_SDK_ENABLED ?= "0"
-TEST_EXPORT_SDK_NAME ?= "testexport-tools-nativesdk"
-TEST_EXPORT_SDK_DIR ?= "sdk"
 
 TEST_EXPORT_DEPENDS = ""
 TEST_EXPORT_DEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
diff --git a/meta/conf/testexport.conf b/meta/conf/testexport.conf
new file mode 100644
index 00000000000..d7c28de7a75
--- /dev/null
+++ b/meta/conf/testexport.conf
@@ -0,0 +1,3 @@ 
+TEST_EXPORT_SDK_PACKAGES ?= ""
+TEST_EXPORT_SDK_DIR ?= "sdk"
+TEST_EXPORT_SDK_NAME ?= "testexport-tools-nativesdk"
\ No newline at end of file
diff --git a/meta/recipes-core/meta/testexport-tarball.bb b/meta/recipes-core/meta/testexport-tarball.bb
index bb9f8ded48c..abdd0092528 100644
--- a/meta/recipes-core/meta/testexport-tarball.bb
+++ b/meta/recipes-core/meta/testexport-tarball.bb
@@ -4,7 +4,7 @@  DESCRIPTION = "SDK type target for standalone tarball containing packages define
 SUMMARY = "Standalone tarball for test systems with missing software"
 LICENSE = "MIT"
 
-TEST_EXPORT_SDK_PACKAGES ??= ""
+require conf/testexport.conf
 
 TOOLCHAIN_TARGET_TASK ?= ""