diff mbox series

[4/5] unzip: Enable largefile support when enabled in distro

Message ID 20220811055433.819522-4-raj.khem@gmail.com
State Accepted, archived
Commit 740a0bcdf63606aebc07861fd563c80c11caaaef
Headers show
Series [1/5] zip: Enable largefile support based on distro feature | expand

Commit Message

Khem Raj Aug. 11, 2022, 5:54 a.m. UTC
The test to determine largefile support is a runtime test which wont
work during cross-compile, therefore override the test result from
recipe

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-extended/unzip/unzip_6.0.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-extended/unzip/unzip_6.0.bb b/meta/recipes-extended/unzip/unzip_6.0.bb
index 15235540890..96068eefdd2 100644
--- a/meta/recipes-extended/unzip/unzip_6.0.bb
+++ b/meta/recipes-extended/unzip/unzip_6.0.bb
@@ -46,6 +46,8 @@  UPSTREAM_CHECK_REGEX = "unzip(?P<pver>(?!552).+)\.tgz"
 
 S = "${WORKDIR}/unzip60"
 
+CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '-DLARGE_FILE_SUPPORT', '', d)}"
+
 # Makefile uses CF_NOOPT instead of CFLAGS.  We lifted the values from
 # Makefile and add CFLAGS.  Optimization will be overriden by unzip
 # configure to be -O3.