libsdl2: add back xvm and xinerama options

Message ID 20220525055556.31026-1-Qi.Chen@windriver.com
State Accepted, archived
Commit 2c5d78153614fcdf30dbe3e41d88f18e9ae06684
Headers show
Series libsdl2: add back xvm and xinerama options | expand

Commit Message

ChenQi May 25, 2022, 5:55 a.m. UTC
When building libsdl2-native, and I met a do_configure error as below.

  | CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
  | Please set them or make sure they are set and tested correctly in the CMake files:
  | XINERAMA_LIB

This error appears on hosts with libxinerama-dev installed.

Looking at the CMakeLists.txt file, I got:

  set(SDL_X11_OPTIONS Xcursor Xdbe Xinerama XInput Xfixes Xrandr Xscrnsaver XShape Xvm

We an see neither Xinerama nor Xvm is removed. So we should add back
these options removed by a previous commit.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Pavel Zhukov May 25, 2022, 6:40 a.m. UTC | #1
I've reported this yesterday.
https://bugzilla.yoctoproject.org/show_bug.cgi?id=14812 Feel free to
close this bug once the patch is merged :-)

"Chen Qi" <Qi.Chen@windriver.com> writes:

> When building libsdl2-native, and I met a do_configure error as below.
>
>   | CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
>   | Please set them or make sure they are set and tested correctly in the CMake files:
>   | XINERAMA_LIB
>
> This error appears on hosts with libxinerama-dev installed.
>
> Looking at the CMakeLists.txt file, I got:
>
>   set(SDL_X11_OPTIONS Xcursor Xdbe Xinerama XInput Xfixes Xrandr Xscrnsaver XShape Xvm
>
> We an see neither Xinerama nor Xvm is removed. So we should add back
> these options removed by a previous commit.
>
> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> ---
>  meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
> index b112d63784..8519e7f732 100644
> --- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
> +++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
> @@ -43,7 +43,9 @@ EXTRA_OECMAKE = "-DSDL_OSS=OFF -DSDL_ESD=OFF -DSDL_ARTS=OFF \
>                   -DSDL_PTHREADS=ON \
>                   -DSDL_RPATH=OFF \
>                   -DSDL_SNDIO=OFF \
> +                 -DSDL_X11_XVM=OFF \
>                   -DSDL_X11_XCURSOR=OFF \
> +                 -DSDL_X11_XINERAMA=OFF \
>                   -DSDL_X11_XDBE=OFF \
>                   -DSDL_X11_XFIXES=OFF \
>                   -DSDL_X11_XINPUT=OFF \
Markus Volk May 25, 2022, 10:22 a.m. UTC | #2
xinerama has indeed been removed. unfortunately the commit doesn't seem 
to be in the 2.0.22 release yet like i thought it would be

https://github.com/libsdl-org/SDL/commit/7d7ec9c95146c44d4b4643ed552796bf07937057

Markus

Am 25.05.22 um 07:55 schrieb Chen Qi:
> When building libsdl2-native, and I met a do_configure error as below.
>
>    | CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
>    | Please set them or make sure they are set and tested correctly in the CMake files:
>    | XINERAMA_LIB
>
> This error appears on hosts with libxinerama-dev installed.
>
> Looking at the CMakeLists.txt file, I got:
>
>    set(SDL_X11_OPTIONS Xcursor Xdbe Xinerama XInput Xfixes Xrandr Xscrnsaver XShape Xvm
>
> We an see neither Xinerama nor Xvm is removed. So we should add back
> these options removed by a previous commit.
>
> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> ---
>   meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb | 2 ++
>   1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
> index b112d63784..8519e7f732 100644
> --- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
> +++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
> @@ -43,7 +43,9 @@ EXTRA_OECMAKE = "-DSDL_OSS=OFF -DSDL_ESD=OFF -DSDL_ARTS=OFF \
>                    -DSDL_PTHREADS=ON \
>                    -DSDL_RPATH=OFF \
>                    -DSDL_SNDIO=OFF \
> +                 -DSDL_X11_XVM=OFF \
>                    -DSDL_X11_XCURSOR=OFF \
> +                 -DSDL_X11_XINERAMA=OFF \
>                    -DSDL_X11_XDBE=OFF \
>                    -DSDL_X11_XFIXES=OFF \
>                    -DSDL_X11_XINPUT=OFF \
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#166094): https://lists.openembedded.org/g/openembedded-core/message/166094
> Mute This Topic: https://lists.openembedded.org/mt/91327899/3618223
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [f_l_k@t-online.de]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
index b112d63784..8519e7f732 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.22.bb
@@ -43,7 +43,9 @@  EXTRA_OECMAKE = "-DSDL_OSS=OFF -DSDL_ESD=OFF -DSDL_ARTS=OFF \
                  -DSDL_PTHREADS=ON \
                  -DSDL_RPATH=OFF \
                  -DSDL_SNDIO=OFF \
+                 -DSDL_X11_XVM=OFF \
                  -DSDL_X11_XCURSOR=OFF \
+                 -DSDL_X11_XINERAMA=OFF \
                  -DSDL_X11_XDBE=OFF \
                  -DSDL_X11_XFIXES=OFF \
                  -DSDL_X11_XINPUT=OFF \