[2/4] eudev: Add PACKAGECONFIG for manpages & selinux

Message ID 20220507064449.25809-2-alex.kiernan@gmail.com
State Accepted, archived
Commit e6c18c9d9d0e11a6a93cca14dbe622707cf25515
Headers show
Series [1/4] eudev: Upgrade 3.2.10 -> 3.2.11 | expand

Commit Message

Alex Kiernan May 7, 2022, 6:44 a.m. UTC
Drop DEPENDS on libxslt-native which is unused as the tarball includes
the manpages and the build process never invokes the script which
regenerates them (make.sh)

Signed-off-by: Alex Kiernan <alexk@zuma.ai>
Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com>
---
 meta/recipes-core/udev/eudev_3.2.11.bb | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

Patch

diff --git a/meta/recipes-core/udev/eudev_3.2.11.bb b/meta/recipes-core/udev/eudev_3.2.11.bb
index 49fa9a74c3da..276456ae460c 100644
--- a/meta/recipes-core/udev/eudev_3.2.11.bb
+++ b/meta/recipes-core/udev/eudev_3.2.11.bb
@@ -5,7 +5,7 @@  LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
 LICENSE:libudev = "LGPL-2.1-or-later"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-DEPENDS = "glib-2.0 glib-2.0-native gperf-native kmod libxslt-native util-linux"
+DEPENDS = "glib-2.0 glib-2.0-native gperf-native kmod util-linux"
 
 PROVIDES = "udev"
 
@@ -16,7 +16,7 @@  SRC_URI = "https://github.com/eudev-project/${BPN}/releases/download/v${PV}/${BP
 
 SRC_URI[sha256sum] = "19847cafec67897da855fde56f9dc7d92e21c50e450aa79068a7e704ed44558b"
 
-inherit autotools update-rc.d qemu pkgconfig features_check
+inherit autotools update-rc.d qemu pkgconfig features_check manpages
 
 CONFLICT_DISTRO_FEATURES = "systemd"
 
@@ -27,8 +27,12 @@  EXTRA_OECONF = " \
     --with-rootprefix= \
 "
 
-PACKAGECONFIG ??= "hwdb"
+PACKAGECONFIG ?= "hwdb \
+                  ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \
+"
 PACKAGECONFIG[hwdb] = "--enable-hwdb,--disable-hwdb"
+PACKAGECONFIG[manpages] = "--enable-manpages,--disable-manpages"
+PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
 
 do_install:append() {
 	install -d ${D}${sysconfdir}/init.d