go-helloworld: remove unused GO_WORKDIR

Message ID 20220429022238.38588-1-Qi.Chen@windriver.com
State Accepted, archived
Commit 70bc5b6d40f94bde82415fb87db37fdf2606c2fb
Headers show
Series go-helloworld: remove unused GO_WORKDIR | expand

Commit Message

ChenQi April 29, 2022, 2:22 a.m. UTC
The GO_WORKDIR is used only in go-mod.bbclass. As this recipe does
not inherit go-mod.bbclass, this variable is useless here.

This go-helloworld recipe was made to inherit go-mod.bbclass and build
in module-aware mode. However, it was found that we need to build go
recipes in GOPATH mode in order to support offline build. As a result,
this recipe was changed back to only inherit go.bbclass. But the GO_WORKDIR
setting was not cleaned up.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 meta/recipes-extended/go-examples/go-helloworld_0.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj April 29, 2022, 4:47 a.m. UTC | #1
lgtm, thanks for fixing it

On Thu, Apr 28, 2022 at 7:23 PM Chen Qi <Qi.Chen@windriver.com> wrote:
>
> The GO_WORKDIR is used only in go-mod.bbclass. As this recipe does
> not inherit go-mod.bbclass, this variable is useless here.
>
> This go-helloworld recipe was made to inherit go-mod.bbclass and build
> in module-aware mode. However, it was found that we need to build go
> recipes in GOPATH mode in order to support offline build. As a result,
> this recipe was changed back to only inherit go.bbclass. But the GO_WORKDIR
> setting was not cleaned up.
>
> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> ---
>  meta/recipes-extended/go-examples/go-helloworld_0.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
> index 0faab39b66..d0de035921 100644
> --- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
> +++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
> @@ -11,7 +11,7 @@ UPSTREAM_CHECK_COMMITS = "1"
>
>  GO_IMPORT = "golang.org/x/example"
>  GO_INSTALL = "${GO_IMPORT}/hello"
> -GO_WORKDIR = "${GO_INSTALL}"
> +
>  export GO111MODULE="off"
>
>  inherit go
> --
> 2.17.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#164986): https://lists.openembedded.org/g/openembedded-core/message/164986
> Mute This Topic: https://lists.openembedded.org/mt/90768475/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index 0faab39b66..d0de035921 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -11,7 +11,7 @@  UPSTREAM_CHECK_COMMITS = "1"
 
 GO_IMPORT = "golang.org/x/example"
 GO_INSTALL = "${GO_IMPORT}/hello"
-GO_WORKDIR = "${GO_INSTALL}"
+
 export GO111MODULE="off"
 
 inherit go