[1/4] alsa-tools: Ensure we install correctly

Message ID 20220415113758.2290861-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 72299395b06fc3fdaca5f7b8b87a6ea32a6267ad
Headers show
Series [1/4] alsa-tools: Ensure we install correctly | expand

Commit Message

Richard Purdie April 15, 2022, 11:37 a.m. UTC
With the fix for #8621, cleandirs is now applied to autotools_do_install
and this results in a lot of the install targets to be removed. Ensure
cleandirs isn't set for autotools_do_install.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-multimedia/alsa/alsa-tools_1.2.5.bb | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.2.5.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.2.5.bb
index b0832f93c11..56acc84559d 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.2.5.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.2.5.bb
@@ -71,6 +71,7 @@  python do_compile() {
 }
 
 python do_install() {
+    d.delVarFlag("autotools_do_install", "cleandirs")
     for subdir in d.getVar("PACKAGECONFIG").split():
         subdir = subdir.replace("--", "/")
         bb.note("Installing %s" % subdir)