[6/6] pango: Skip test-layout ptest

Message ID 20220414025230.1166825-6-raj.khem@gmail.com
State Accepted, archived
Commit 9c427fd674320253bb99f8885f1667398f59aba4
Headers show
Series [1/6] riscv: Add tunes for rv64 without compressed instructions | expand

Commit Message

Khem Raj April 14, 2022, 2:52 a.m. UTC
This has intermittent behavior, is sensitive to harfbuzz version

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../0001-Skip-running-test-layout-test.patch  | 45 +++++++++++++++++++
 meta/recipes-graphics/pango/pango_1.50.6.bb   |  4 +-
 2 files changed, 48 insertions(+), 1 deletion(-)
 create mode 100644 meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch

Comments

Alexander Kanavin April 14, 2022, 3:33 a.m. UTC | #1
Please do file an upstream bug and include a link to it.

Alex

On Thu 14. Apr 2022 at 4.52, Khem Raj <raj.khem@gmail.com> wrote:

> This has intermittent behavior, is sensitive to harfbuzz version
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  .../0001-Skip-running-test-layout-test.patch  | 45 +++++++++++++++++++
>  meta/recipes-graphics/pango/pango_1.50.6.bb   |  4 +-
>  2 files changed, 48 insertions(+), 1 deletion(-)
>  create mode 100644
> meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch
>
> diff --git
> a/meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch
> b/meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch
> new file mode 100644
> index 00000000000..c391e158d28
> --- /dev/null
> +++
> b/meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch
> @@ -0,0 +1,45 @@
> +From b9bfe3a79f165682a6db3d7ee1928365e93b1ccf Mon Sep 17 00:00:00 2001
> +From: Khem Raj <raj.khem@gmail.com>
> +Date: Wed, 13 Apr 2022 19:39:29 -0700
> +Subject: [PATCH] Skip running test-layout test
> +
> +This fails intermittently, it varies based on what version of harfbuzz
> +is installed and if it does not match with what pango CI tests then we
> +get random failures in this test. This has been disabled in other
> +distros [1] too
> +
> +We want to drop this on next upgrade and see if this test passes if not
> +then keep it disabled
> +
> +Fixes
> +
> +Running test: pango/test-layout.test
> +1..36
> +ok 1 /layout/letterspacing.layout
> +ok 2 /layout/valid-7.layout
> +not ok 3 /layout/valid-14.layout
> +Bail out!
> +FAIL: pango/test-layout.test (Child process killed by signal 6)
> +
> +[1]
> https://github.com/archlinux/svntogit-packages/commit/3f883e7ff8071adad23b6bcc0ba4b995aff10d52
> +
> +Upstream-Status: Inappropriate [Distro specific]
> +Signed-off-by: Khem Raj <raj.khem@gmail.com>
> +---
> + tests/test-layout.c | 2 +-
> + 1 file changed, 1 insertion(+), 1 deletion(-)
> +
> +diff --git a/tests/test-layout.c b/tests/test-layout.c
> +index 1139e4f..b47a066 100644
> +--- a/tests/test-layout.c
> ++++ b/tests/test-layout.c
> +@@ -222,5 +222,5 @@ main (int argc, char *argv[])
> +     }
> +   g_dir_close (dir);
> +
> +-  return g_test_run ();
> ++  return 77;
> + }
> +--
> +2.35.2
> +
> diff --git a/meta/recipes-graphics/pango/pango_1.50.6.bb
> b/meta/recipes-graphics/pango/pango_1.50.6.bb
> index cd04801db10..93e16534641 100644
> --- a/meta/recipes-graphics/pango/pango_1.50.6.bb
> +++ b/meta/recipes-graphics/pango/pango_1.50.6.bb
> @@ -18,7 +18,9 @@ inherit gnomebase gi-docgen ptest-gnome
> upstream-version-is-even gobject-introsp
>  GIR_MESON_ENABLE_FLAG = "enabled"
>  GIR_MESON_DISABLE_FLAG = "disabled"
>
> -SRC_URI += "file://run-ptest"
> +SRC_URI += "file://run-ptest \
> +            file://0001-Skip-running-test-layout-test.patch \
> +"
>
>  SRC_URI[archive.sha256sum] =
> "a998bcf36881c3ac20495d40bceb304f4eaa9175bd2967c85656434cbdafe86a"
>
> --
> 2.35.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#164383):
> https://lists.openembedded.org/g/openembedded-core/message/164383
> Mute This Topic: https://lists.openembedded.org/mt/90456793/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>

Patch

diff --git a/meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch b/meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch
new file mode 100644
index 00000000000..c391e158d28
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango/0001-Skip-running-test-layout-test.patch
@@ -0,0 +1,45 @@ 
+From b9bfe3a79f165682a6db3d7ee1928365e93b1ccf Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 13 Apr 2022 19:39:29 -0700
+Subject: [PATCH] Skip running test-layout test
+
+This fails intermittently, it varies based on what version of harfbuzz
+is installed and if it does not match with what pango CI tests then we
+get random failures in this test. This has been disabled in other
+distros [1] too
+
+We want to drop this on next upgrade and see if this test passes if not
+then keep it disabled
+
+Fixes
+
+Running test: pango/test-layout.test
+1..36
+ok 1 /layout/letterspacing.layout
+ok 2 /layout/valid-7.layout
+not ok 3 /layout/valid-14.layout
+Bail out!
+FAIL: pango/test-layout.test (Child process killed by signal 6)
+
+[1] https://github.com/archlinux/svntogit-packages/commit/3f883e7ff8071adad23b6bcc0ba4b995aff10d52
+
+Upstream-Status: Inappropriate [Distro specific]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tests/test-layout.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test-layout.c b/tests/test-layout.c
+index 1139e4f..b47a066 100644
+--- a/tests/test-layout.c
++++ b/tests/test-layout.c
+@@ -222,5 +222,5 @@ main (int argc, char *argv[])
+     }
+   g_dir_close (dir);
+ 
+-  return g_test_run ();
++  return 77;
+ }
+-- 
+2.35.2
+
diff --git a/meta/recipes-graphics/pango/pango_1.50.6.bb b/meta/recipes-graphics/pango/pango_1.50.6.bb
index cd04801db10..93e16534641 100644
--- a/meta/recipes-graphics/pango/pango_1.50.6.bb
+++ b/meta/recipes-graphics/pango/pango_1.50.6.bb
@@ -18,7 +18,9 @@  inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introsp
 GIR_MESON_ENABLE_FLAG = "enabled"
 GIR_MESON_DISABLE_FLAG = "disabled"
 
-SRC_URI += "file://run-ptest"
+SRC_URI += "file://run-ptest \
+            file://0001-Skip-running-test-layout-test.patch \
+"
 
 SRC_URI[archive.sha256sum] = "a998bcf36881c3ac20495d40bceb304f4eaa9175bd2967c85656434cbdafe86a"