[02/17] llvm: update 13.0.1 -> 14.0.0

Message ID 20220407170029.3500874-2-alex@linutronix.de
State Accepted, archived
Commit ee06fc2a19665461e143fe3bf7e94b703652e1cf
Headers show
Series [01/17] connman-conf: ignore eth0 in qemu in a way that is not sysvinit-specific | expand

Commit Message

Alexander Kanavin April 7, 2022, 5 p.m. UTC
llvm-config no longer links with libLLVM, so there is no need
to install it in -native (and it isn't built in the first place).
This also significantly speeds up llvm-native build.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/conf/distro/include/tcmode-default.inc | 2 +-
 meta/recipes-devtools/llvm/llvm_git.bb      | 5 ++---
 2 files changed, 3 insertions(+), 4 deletions(-)

Comments

Richard Purdie April 8, 2022, 7:03 a.m. UTC | #1
On Thu, 2022-04-07 at 19:00 +0200, Alexander Kanavin wrote:
> llvm-config no longer links with libLLVM, so there is no need
> to install it in -native (and it isn't built in the first place).
> This also significantly speeds up llvm-native build.
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  meta/conf/distro/include/tcmode-default.inc | 2 +-
>  meta/recipes-devtools/llvm/llvm_git.bb      | 5 ++---
>  2 files changed, 3 insertions(+), 4 deletions(-)

There is something not quite right with one of the llvm changes:

https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5022
https://autobuilder.yoctoproject.org/typhoon/#/builders/72/builds/5043/steps/32/logs/stdio

Cheers,

Richard
Alexander Kanavin April 8, 2022, 8:12 a.m. UTC | #2
On Fri, 8 Apr 2022 at 09:03, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> There is something not quite right with one of the llvm changes:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/64/builds/5022
> https://autobuilder.yoctoproject.org/typhoon/#/builders/72/builds/5043/steps/32/logs/stdio

This bit:
+ # llvm harcodes usr/lib as install path, so this corrects it to actual libdir
+ mv -T -n ${D}/${prefix}/lib ${D}/${libdir}

On my distros '-n -T' is enough to guard against renaming into itself
becoming an error, but apparently older mv still errors out. Perhaps
appending '|| true' will do the trick, can you make that adjustment?

Alex

Patch

diff --git a/meta/conf/distro/include/tcmode-default.inc b/meta/conf/distro/include/tcmode-default.inc
index d362bd76c6..4a6d4da5d5 100644
--- a/meta/conf/distro/include/tcmode-default.inc
+++ b/meta/conf/distro/include/tcmode-default.inc
@@ -26,7 +26,7 @@  QEMUVERSION ?= "6.2%"
 GOVERSION ?= "1.17%"
 # This can not use wildcards like 8.0.% since it is also used in mesa to denote
 # llvm version being used, so always bump it with llvm recipe version bump
-LLVMVERSION ?= "13.0.1"
+LLVMVERSION ?= "14.0.0"
 RUSTVERSION ?= "1.59%"
 
 PREFERRED_VERSION_gcc ?= "${GCCVERSION}"
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 9400bf0821..13f7fb763e 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -19,7 +19,7 @@  inherit cmake pkgconfig
 
 PROVIDES += "llvm${PV}"
 
-PV = "13.0.1"
+PV = "14.0.0"
 
 MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
 
@@ -27,7 +27,7 @@  LLVM_RELEASE = "${PV}"
 LLVM_DIR = "llvm${LLVM_RELEASE}"
 
 BRANCH = "release/${MAJOR_VERSION}.x"
-SRCREV = "75e33f71c2dae584b13a7d1186ae0a038ba98838"
+SRCREV = "329fda39c507e8740978d10458451dcdb21563be"
 SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
            file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
            file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
@@ -145,7 +145,6 @@  do_install() {
 do_install:class-native() {
 	install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV}
 	install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV}
-	install -D -m 0755 ${B}/lib/libLLVM-${MAJOR_VERSION}.so ${D}${libdir}/libLLVM-${MAJOR_VERSION}.so
 }
 
 PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto"