python3: Add a dependency on ncurses

Message ID 20220327055051.17188-1-pkj@axis.com
State Accepted, archived
Commit 70e0641069ca1e0e460000fe19662d6b3753b2ba
Headers show
Series python3: Add a dependency on ncurses | expand

Commit Message

Peter Kjellerstedt March 27, 2022, 5:50 a.m. UTC
This avoids the following configuration error:

  The necessary bits to build these optional modules were not found:
  _curses               _curses_panel

which happens if the "readline" PACKAGECONFIG is disabled.

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---
 meta/recipes-devtools/python/python3_3.10.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-devtools/python/python3_3.10.3.bb b/meta/recipes-devtools/python/python3_3.10.3.bb
index 4e7c6f71e3..5c0f0a9eb2 100644
--- a/meta/recipes-devtools/python/python3_3.10.3.bb
+++ b/meta/recipes-devtools/python/python3_3.10.3.bb
@@ -70,7 +70,7 @@  ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config
 ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
 
 
-DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native"
+DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native ncurses"
 DEPENDS:append:class-target = " python3-native"
 DEPENDS:append:class-nativesdk = " python3-native"