[2/2] shadow-native: Simplify and fix syslog disable patch

Message ID 20220314175732.827665-2-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 8f1816862b884f226c0ce7f5c89fd75b6791c007
Headers show
Series [1/2] scripts/runqemu: Fix memory limits for qemux86-64 | expand

Commit Message

Richard Purdie March 14, 2022, 5:57 p.m. UTC
Shadow is happily spamming the host syslog with messages and shouldn't be
which suggests the patch isn't working. Redo it to work at the configure
level which is simpler and hopefully more effective.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 ...01-Disable-use-of-syslog-for-sysroot.patch | 122 ++----------------
 1 file changed, 13 insertions(+), 109 deletions(-)

Comments

Peter Kjellerstedt March 14, 2022, 7:10 p.m. UTC | #1
> -----Original Message-----
> From: openembedded-core@lists.openembedded.org <openembedded-core@lists.openembedded.org> On Behalf Of Richard Purdie
> Sent: den 14 mars 2022 18:58
> To: openembedded-core@lists.openembedded.org
> Subject: [OE-core] [PATCH 2/2] shadow-native: Simplify and fix syslog disable patch
> 
> Shadow is happily spamming the host syslog with messages and shouldn't be
> which suggests the patch isn't working. Redo it to work at the configure
> level which is simpler and hopefully more effective.
> 
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
>  ...01-Disable-use-of-syslog-for-sysroot.patch | 122 ++----------------
>  1 file changed, 13 insertions(+), 109 deletions(-)
> 
> diff --git a/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch b/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch
> index 4d6f6d68ec2..23640824f14 100644
> --- a/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch
> +++ b/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch
> @@ -13,112 +13,16 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
>  Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
>  Signed-off-by: Chen Qi <Qi.Chen@windriver.com>

Since this is a completely new patch you should replace the 
Signed-off-by's above as they obviously no longer apply.

> 
> ----
> - src/groupadd.c  | 3 +++
> - src/groupdel.c  | 3 +++
> - src/groupmems.c | 3 +++
> - src/groupmod.c  | 3 +++
> - src/useradd.c   | 3 +++
> - src/userdel.c   | 4 ++++
> - src/usermod.c   | 3 +++
> - 7 files changed, 22 insertions(+)
> -
> -diff --git a/src/groupadd.c b/src/groupadd.c
> -index 66ccb53..776ea51 100644
> ---- a/src/groupadd.c
> -+++ b/src/groupadd.c
> -@@ -11,6 +11,9 @@
> -
> - #ident "$Id$"
> -
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <ctype.h>
> - #include <fcntl.h>
> - #include <getopt.h>
> -diff --git a/src/groupdel.c b/src/groupdel.c
> -index c84faa7..1076f4b 100644
> ---- a/src/groupdel.c
> -+++ b/src/groupdel.c
> -@@ -11,6 +11,9 @@
> -
> - #ident "$Id$"
> -
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <ctype.h>
> - #include <fcntl.h>
> - #include <grp.h>
> -diff --git a/src/groupmems.c b/src/groupmems.c
> -index a0e3266..6540cb1 100644
> ---- a/src/groupmems.c
> -+++ b/src/groupmems.c
> -@@ -9,6 +9,9 @@
> -
> - #include <config.h>
> -
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <fcntl.h>
> - #include <getopt.h>
> - #include <grp.h>
> -diff --git a/src/groupmod.c b/src/groupmod.c
> -index 006eca1..78b1ad6 100644
> ---- a/src/groupmod.c
> -+++ b/src/groupmod.c
> -@@ -11,6 +11,9 @@
> -
> - #ident "$Id$"
> -
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <ctype.h>
> - #include <fcntl.h>
> - #include <getopt.h>
> -diff --git a/src/useradd.c b/src/useradd.c
> -index 456b9de..2b0d703 100644
> ---- a/src/useradd.c
> -+++ b/src/useradd.c
> -@@ -11,6 +11,9 @@
> -
> - #ident "$Id$"
> -
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <assert.h>
> - #include <ctype.h>
> - #include <errno.h>
> -diff --git a/src/userdel.c b/src/userdel.c
> -index 7012b0e..08bb5d1 100644
> ---- a/src/userdel.c
> -+++ b/src/userdel.c
> -@@ -8,6 +8,10 @@
> -  */
> -
> - #include <config.h>
> -+
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <assert.h>
> - #include <dirent.h>
> - #include <errno.h>
> -diff --git a/src/usermod.c b/src/usermod.c
> -index 9473a7d..7d4f7b5 100644
> ---- a/src/usermod.c
> -+++ b/src/usermod.c
> -@@ -11,6 +11,9 @@
> -
> - #ident "$Id$"
> -
> -+/* Disable use of syslog since we're running this command against a sysroot */
> -+#undef USE_SYSLOG
> -+
> - #include <assert.h>
> - #include <ctype.h>
> - #include <errno.h>
> +Index: shadow-4.11.1/configure.ac
> +===================================================================
> +--- shadow-4.11.1.orig/configure.ac
> ++++ shadow-4.11.1/configure.ac
> +@@ -204,7 +204,7 @@ AC_DEFINE_UNQUOTED(PASSWD_PROGRAM, "$sha
> + 	[Path to passwd program.])
> +
> + dnl XXX - quick hack, should disappear before anyone notices :).
> +-AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().])
> ++AC_DEFINE(USE_SYSLOG, 0, [Define to use syslog().])
> + if test "$ac_cv_func_ruserok" = "yes"; then
> + 	AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
> + 	AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).])
> --
> 2.32.0

//Peter
Richard Purdie March 14, 2022, 11 p.m. UTC | #2
On Mon, 2022-03-14 at 19:10 +0000, Peter Kjellerstedt wrote:
> > -----Original Message-----
> > From: openembedded-core@lists.openembedded.org
> > <openembedded-core@lists.openembedded.org> On Behalf Of Richard Purdie
> > Sent: den 14 mars 2022 18:58
> > To: openembedded-core@lists.openembedded.org
> > Subject: [OE-core] [PATCH 2/2] shadow-native: Simplify and fix syslog
> > disable patch
> > 
> > Shadow is happily spamming the host syslog with messages and shouldn't be
> > which suggests the patch isn't working. Redo it to work at the configure
> > level which is simpler and hopefully more effective.
> > 
> > Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> > ---
> >  ...01-Disable-use-of-syslog-for-sysroot.patch | 122 ++----------------
> >  1 file changed, 13 insertions(+), 109 deletions(-)
> > 
> > diff --git a/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-
> > for-sysroot.patch b/meta/recipes-extended/shadow/files/0001-Disable-use-of-
> > syslog-for-sysroot.patch
> > index 4d6f6d68ec2..23640824f14 100644
> > --- a/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-
> > sysroot.patch
> > +++ b/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-
> > sysroot.patch
> > @@ -13,112 +13,16 @@ Signed-off-by: Scott Garman <scott.a.garman@intel.com>
> >  Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
> >  Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> 
> Since this is a completely new patch you should replace the 
> Signed-off-by's above as they obviously no longer apply.

I've removed them on the branch.

Cheers,

Richard

Patch

diff --git a/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch b/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch
index 4d6f6d68ec2..23640824f14 100644
--- a/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch
+++ b/meta/recipes-extended/shadow/files/0001-Disable-use-of-syslog-for-sysroot.patch
@@ -13,112 +13,16 @@  Signed-off-by: Scott Garman <scott.a.garman@intel.com>
 Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
 Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
 
----
- src/groupadd.c  | 3 +++
- src/groupdel.c  | 3 +++
- src/groupmems.c | 3 +++
- src/groupmod.c  | 3 +++
- src/useradd.c   | 3 +++
- src/userdel.c   | 4 ++++
- src/usermod.c   | 3 +++
- 7 files changed, 22 insertions(+)
-
-diff --git a/src/groupadd.c b/src/groupadd.c
-index 66ccb53..776ea51 100644
---- a/src/groupadd.c
-+++ b/src/groupadd.c
-@@ -11,6 +11,9 @@
- 
- #ident "$Id$"
- 
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <ctype.h>
- #include <fcntl.h>
- #include <getopt.h>
-diff --git a/src/groupdel.c b/src/groupdel.c
-index c84faa7..1076f4b 100644
---- a/src/groupdel.c
-+++ b/src/groupdel.c
-@@ -11,6 +11,9 @@
- 
- #ident "$Id$"
- 
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <ctype.h>
- #include <fcntl.h>
- #include <grp.h>
-diff --git a/src/groupmems.c b/src/groupmems.c
-index a0e3266..6540cb1 100644
---- a/src/groupmems.c
-+++ b/src/groupmems.c
-@@ -9,6 +9,9 @@
- 
- #include <config.h>
- 
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <fcntl.h>
- #include <getopt.h>
- #include <grp.h>
-diff --git a/src/groupmod.c b/src/groupmod.c
-index 006eca1..78b1ad6 100644
---- a/src/groupmod.c
-+++ b/src/groupmod.c
-@@ -11,6 +11,9 @@
- 
- #ident "$Id$"
- 
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <ctype.h>
- #include <fcntl.h>
- #include <getopt.h>
-diff --git a/src/useradd.c b/src/useradd.c
-index 456b9de..2b0d703 100644
---- a/src/useradd.c
-+++ b/src/useradd.c
-@@ -11,6 +11,9 @@
- 
- #ident "$Id$"
- 
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <assert.h>
- #include <ctype.h>
- #include <errno.h>
-diff --git a/src/userdel.c b/src/userdel.c
-index 7012b0e..08bb5d1 100644
---- a/src/userdel.c
-+++ b/src/userdel.c
-@@ -8,6 +8,10 @@
-  */
- 
- #include <config.h>
-+
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <assert.h>
- #include <dirent.h>
- #include <errno.h>
-diff --git a/src/usermod.c b/src/usermod.c
-index 9473a7d..7d4f7b5 100644
---- a/src/usermod.c
-+++ b/src/usermod.c
-@@ -11,6 +11,9 @@
- 
- #ident "$Id$"
- 
-+/* Disable use of syslog since we're running this command against a sysroot */
-+#undef USE_SYSLOG
-+
- #include <assert.h>
- #include <ctype.h>
- #include <errno.h>
+Index: shadow-4.11.1/configure.ac
+===================================================================
+--- shadow-4.11.1.orig/configure.ac
++++ shadow-4.11.1/configure.ac
+@@ -204,7 +204,7 @@ AC_DEFINE_UNQUOTED(PASSWD_PROGRAM, "$sha
+ 	[Path to passwd program.])
+ 
+ dnl XXX - quick hack, should disappear before anyone notices :).
+-AC_DEFINE(USE_SYSLOG, 1, [Define to use syslog().])
++AC_DEFINE(USE_SYSLOG, 0, [Define to use syslog().])
+ if test "$ac_cv_func_ruserok" = "yes"; then
+ 	AC_DEFINE(RLOGIN, 1, [Define if login should support the -r flag for rlogind.])
+ 	AC_DEFINE(RUSEROK, 0, [Define to the ruserok() "success" return value (0 or 1).])