[5/5] go: Remove three unnecessary paths from do_compile[dirs]

Message ID 20220314141647.14807-5-pkj@axis.com
State Accepted, archived
Commit 9f610748f760b2d58d5250b55ae4b268909f33ef
Headers show
Series [1/5] create-spdx.bbclass: Remove an unnecessary path from do_create_spdx[dirs] | expand

Commit Message

Peter Kjellerstedt March 14, 2022, 2:16 p.m. UTC
From: Peter Kjellerstedt <peter.kjellerstedt@axis.com>

There is no reason to include a path in foo[dirs] if it is also in
foo[cleandirs] (except if it is the last path in foo[dirs]).

Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
---
 meta/recipes-devtools/go/go-cross-canadian.inc | 1 -
 meta/recipes-devtools/go/go-cross.inc          | 1 -
 meta/recipes-devtools/go/go-crosssdk.inc       | 1 -
 meta/recipes-devtools/go/go-native_1.17.8.bb   | 1 -
 meta/recipes-devtools/go/go-runtime.inc        | 1 -
 meta/recipes-devtools/go/go-target.inc         | 1 -
 6 files changed, 6 deletions(-)

Patch

diff --git a/meta/recipes-devtools/go/go-cross-canadian.inc b/meta/recipes-devtools/go/go-cross-canadian.inc
index d49250a8e2..c1aa987427 100644
--- a/meta/recipes-devtools/go/go-cross-canadian.inc
+++ b/meta/recipes-devtools/go/go-cross-canadian.inc
@@ -27,7 +27,6 @@  do_compile() {
 	./make.bash --host-only --no-banner
 	cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 
diff --git a/meta/recipes-devtools/go/go-cross.inc b/meta/recipes-devtools/go/go-cross.inc
index 3d5803bf07..a0fbdbe3b9 100644
--- a/meta/recipes-devtools/go/go-cross.inc
+++ b/meta/recipes-devtools/go/go-cross.inc
@@ -17,7 +17,6 @@  do_compile() {
 	./make.bash --host-only --no-banner
 	cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 make_wrapper() {
diff --git a/meta/recipes-devtools/go/go-crosssdk.inc b/meta/recipes-devtools/go/go-crosssdk.inc
index f0bec79719..cd23cca2fe 100644
--- a/meta/recipes-devtools/go/go-crosssdk.inc
+++ b/meta/recipes-devtools/go/go-crosssdk.inc
@@ -13,7 +13,6 @@  do_compile() {
 	./make.bash --host-only --no-banner
 	cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 make_wrapper() {
diff --git a/meta/recipes-devtools/go/go-native_1.17.8.bb b/meta/recipes-devtools/go/go-native_1.17.8.bb
index ffe4ef3523..76c0ab73a6 100644
--- a/meta/recipes-devtools/go/go-native_1.17.8.bb
+++ b/meta/recipes-devtools/go/go-native_1.17.8.bb
@@ -27,7 +27,6 @@  do_compile() {
 	./make.bash ${GOMAKEARGS}
 	cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin"
 
 make_wrapper() {
diff --git a/meta/recipes-devtools/go/go-runtime.inc b/meta/recipes-devtools/go/go-runtime.inc
index ccb86d4fe9..e18339cddb 100644
--- a/meta/recipes-devtools/go/go-runtime.inc
+++ b/meta/recipes-devtools/go/go-runtime.inc
@@ -38,7 +38,6 @@  do_compile() {
 	fi
 	cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 do_install() {
diff --git a/meta/recipes-devtools/go/go-target.inc b/meta/recipes-devtools/go/go-target.inc
index b0d487ae1c..d085643036 100644
--- a/meta/recipes-devtools/go/go-target.inc
+++ b/meta/recipes-devtools/go/go-target.inc
@@ -29,7 +29,6 @@  do_compile() {
 	./make.bash --target-only --no-banner
 	cd ${B}
 }
-do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin ${B}/pkg"
 do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin ${B}/pkg"
 
 do_install() {