[2/3] linux-yocto: Ignore textrels for ppc64 kernel

Message ID 20220313075932.3031649-2-raj.khem@gmail.com
State Accepted, archived
Commit a7ca98d031c21f7e24878974e3b6b1eb81217862
Headers show
Series [1/3] gcompat: Do not use static-pie on ppc | expand

Commit Message

Khem Raj March 13, 2022, 7:59 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-kernel/linux/linux-yocto_5.15.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Bruce Ashfield March 14, 2022, 2:23 a.m. UTC | #1
On Sun, Mar 13, 2022 at 3:59 AM Khem Raj <raj.khem@gmail.com> wrote:

> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  meta/recipes-kernel/linux/linux-yocto_5.15.bb | 3 +++
>  1 file changed, 3 insertions(+)
>
> diff --git a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
> b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
> index b9715e71eec..9a147023e83 100644
> --- a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
> @@ -66,3 +66,6 @@ KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc
> cfg/paravirt_kvm.scc"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32",
> " cfg/x32.scc", "", d)}"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES",
> "ptest", " features/scsi/scsi-debug.scc", "", d)}"
>  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES",
> "ptest", " features/gpio/mockup.scc", "", d)}"
> +
> +INSANE_SKIP:kernel-vmlinux:qemuppc64 = "textrel"
>

Fine with me. We could also do the same tweak to linux-yocto-dev, when I'm
back from vacation, I'll check on that (if I don't see anything on the
list).

Bruce



> +
> --
> 2.35.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#163103):
> https://lists.openembedded.org/g/openembedded-core/message/163103
> Mute This Topic: https://lists.openembedded.org/mt/89747768/1050810
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> bruce.ashfield@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Khem Raj March 14, 2022, 3:50 a.m. UTC | #2
On Sun, Mar 13, 2022 at 7:24 PM Bruce Ashfield <bruce.ashfield@gmail.com> wrote:
>
>
>
> On Sun, Mar 13, 2022 at 3:59 AM Khem Raj <raj.khem@gmail.com> wrote:
>>
>> Signed-off-by: Khem Raj <raj.khem@gmail.com>
>> ---
>>  meta/recipes-kernel/linux/linux-yocto_5.15.bb | 3 +++
>>  1 file changed, 3 insertions(+)
>>
>> diff --git a/meta/recipes-kernel/linux/linux-yocto_5.15.bb b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
>> index b9715e71eec..9a147023e83 100644
>> --- a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
>> +++ b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
>> @@ -66,3 +66,6 @@ KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
>>  KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
>>  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}"
>>  KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}"
>> +
>> +INSANE_SKIP:kernel-vmlinux:qemuppc64 = "textrel"
>
>
> Fine with me. We could also do the same tweak to linux-yocto-dev, when I'm back from vacation, I'll check on that (if I don't see anything on the list).

I have seen same on latest master as well yes. but scanelf results in
no relocations so I wonder why this section is generated into vmlinux
first of all
secondly, I think our textrel QA check could be made a bit more
accurate by checking for relocations rather than presense of  dynamic
section alone
as trigger point.

I am also think that we should perhaps take advantage of linker option
now a days to flag these textrels during linking stage itself by
enabling
--enable-textrel-check=[yes|no|warning|error] configure option perhaps
set it to 'warn' for now and then turn it into 'error' later when
things are settled.

>
> Bruce
>
>
>>
>> +
>> --
>> 2.35.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#163103): https://lists.openembedded.org/g/openembedded-core/message/163103
>> Mute This Topic: https://lists.openembedded.org/mt/89747768/1050810
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>
>
> --
> - Thou shalt not follow the NULL pointer, for chaos and madness await thee at its end
> - "Use the force Harry" - Gandalf, Star Trek II
>

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto_5.15.bb b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
index b9715e71eec..9a147023e83 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.15.bb
@@ -66,3 +66,6 @@  KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}"
 KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}"
+
+INSANE_SKIP:kernel-vmlinux:qemuppc64 = "textrel"
+