weston-init: add use-pixman PACKAGECONFIG

Message ID 20220312141056.1035449-1-liu.ming50@gmail.com
State Accepted, archived
Commit e3dc3ee5e41caa1691ebdb1c6ed6e51077f9ce7a
Headers show
Series weston-init: add use-pixman PACKAGECONFIG | expand

Commit Message

Ming Liu March 12, 2022, 2:10 p.m. UTC
From: Ming Liu <liu.ming50@gmail.com>

Fbdev backend has been deprecated since weston 10.0.0, and it could be
replaced by passing --use-pixman to drm backend, add a use-pixman
PACKAGECONFIG for convenience.

Signed-off-by: Ming Liu <liu.ming50@gmail.com>
---
 meta/recipes-graphics/wayland/weston-init.bb | 5 +++++
 1 file changed, 5 insertions(+)

Patch

diff --git a/meta/recipes-graphics/wayland/weston-init.bb b/meta/recipes-graphics/wayland/weston-init.bb
index 8e8c0454be..c34582137d 100644
--- a/meta/recipes-graphics/wayland/weston-init.bb
+++ b/meta/recipes-graphics/wayland/weston-init.bb
@@ -17,6 +17,7 @@  S = "${WORKDIR}"
 PACKAGECONFIG ??= ""
 
 PACKAGECONFIG[no-idle-timeout] = ",,"
+PACKAGECONFIG[use-pixman] = ",,"
 
 DEFAULTBACKEND ??= ""
 DEFAULTBACKEND:qemuall ?= "drm"
@@ -51,6 +52,10 @@  do_install() {
 		sed -i -e "/^\[core\]/a idle-time=0" ${D}${sysconfdir}/xdg/weston/weston.ini
 	fi
 
+	if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-pixman', 'yes', 'no', d)}" = "yes" ]; then
+		sed -i -e "/^\[core\]/a use-pixman=true" ${D}${sysconfdir}/xdg/weston/weston.ini
+	fi
+
 	install -dm 755 -o weston -g weston ${D}/home/weston
 }