[2/7] python3-setuptools3: clean up PYPA_WHEEL usage

Message ID 20220308163206.4039089-2-ross.burton@arm.com
State Accepted, archived
Commit c0a24279c740555a06a5c57e2a01ca7b20f8e668
Headers show
Series [1/7] python3-pip: clean up PYPA_WHEEL usage | expand

Commit Message

Ross Burton March 8, 2022, 4:32 p.m. UTC
There's no need to set PYPA_WHEEL as the default is sufficient.

Remove the use of PYPA_WHEEL in the native do_install() as this variable
will be disappearing shortly.

Remove the bbfatal_log in the native do_install(), if this breaks then
something has gone very wrong and the user is not expected to fix it.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-devtools/python/python3-setuptools_59.5.0.bb | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Patch

diff --git a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb b/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
index 2155101d30..9d2c2fd744 100644
--- a/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_59.5.0.bb
@@ -21,13 +21,10 @@  DEPENDS += "${PYTHON_PN}"
 DEPENDS:remove:class-native = "python3-pip-native python3-setuptools-native"
 DEPENDS:append:class-native = " unzip-native"
 
-PYPA_WHEEL ?= "${B}/dist/${PYPI_PACKAGE}-${PV}-*.whl"
-
 do_install:class-native() {
     # Bootstrap to prevent dependency loop in python3-pip-native
     install -d ${D}${PYTHON_SITEPACKAGES_DIR}
-    unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PYPA_WHEEL} || \
-    bbfatal_log "Failed to unzip wheel: ${PYPA_WHEEL}. Check the logs."
+    unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PIP_INSTALL_DIST_PATH}/*.whl
 }
 
 RDEPENDS:${PN} = "\