[2/5] libsdl2: Depend on virtual/egl

Message ID 20220308155252.2454464-2-raj.khem@gmail.com
State Accepted, archived
Commit 26f511bb21c01a371722caa739f4f6d079211cc2
Headers show
Series [1/5] qemu: Depend on virtual/egl | expand

Commit Message

Khem Raj March 8, 2022, 3:52 p.m. UTC
virtual/libgl may not be implemented by some non-mesa graphics in
embedded space, this ensures that libsdl2 can build on such stacks

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ross Burton March 9, 2022, 12:31 p.m. UTC | #1
On Tue, 8 Mar 2022 at 15:52, Khem Raj <raj.khem@gmail.com> wrote:
> -PACKAGECONFIG[opengl]     = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/libgl"
> +PACKAGECONFIG[opengl]     = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/egl"

What does libSDL2 look for, then? Is it EGL explicitly? Or GLX? Or
something else.

I agree that the virtual/libgl thing is a mess, but if we're clearing
it up we need to clear about what is changing.

Ross
Khem Raj March 17, 2022, 2:54 p.m. UTC | #2
On Wed, Mar 9, 2022 at 4:31 AM Ross Burton <ross@burtonini.com> wrote:
>
> On Tue, 8 Mar 2022 at 15:52, Khem Raj <raj.khem@gmail.com> wrote:
> > -PACKAGECONFIG[opengl]     = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/libgl"
> > +PACKAGECONFIG[opengl]     = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/egl"
>
> What does libSDL2 look for, then? Is it EGL explicitly? Or GLX? Or
> something else.

it looks for egl implementation provider which in X case is same as
virtual/libgl provider ( mesa )
in next release I think we should make clear difference between openGL
implementations instead of
specifying pins on libraries

>
> I agree that the virtual/libgl thing is a mess, but if we're clearing
> it up we need to clear about what is changing.
>
> Ross

Patch

diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb
index 90724ab8b79..58bc94cc86b 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.20.bb
@@ -67,7 +67,7 @@  PACKAGECONFIG[directfb]   = "-DSDL_DIRECTFB=ON,-DSDL_DIRECTFB=OFF,directfb,direc
 PACKAGECONFIG[gles2]      = "-DSDL_OPENGLES=ON,-DSDL_OPENGLES=OFF,virtual/libgles2"
 PACKAGECONFIG[jack]       = "-DSDL_JACK=ON,-DSDL_JACK=OFF,jack"
 PACKAGECONFIG[kmsdrm]     = "-DSDL_KMSDRM=ON,-DSDL_KMSDRM=OFF,libdrm virtual/libgbm"
-PACKAGECONFIG[opengl]     = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/libgl"
+PACKAGECONFIG[opengl]     = "-DSDL_OPENGL=ON,-DSDL_OPENGL=OFF,virtual/egl"
 PACKAGECONFIG[pulseaudio] = "-DSDL_PULSEAUDIO=ON,-DSDL_PULSEAUDIO=OFF,pulseaudio"
 PACKAGECONFIG[wayland]    = "-DSDL_WAYLAND=ON,-DSDL_WAYLAND=OFF,wayland-native wayland wayland-protocols libxkbcommon"
 PACKAGECONFIG[x11]        = "-DSDL_X11=ON,-DSDL_X11=OFF,virtual/libx11 libxext libxrandr libxrender"