cmake-native: Remove help docs from the native sysroot

Message ID 20220303153000.332558-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 6e561619a2a2b688735deae968eb66027fd4b9f0
Headers show
Series cmake-native: Remove help docs from the native sysroot | expand

Commit Message

Richard Purdie March 3, 2022, 3:30 p.m. UTC
This drops the file count for cmake-native from ~3000 to ~1700
which is a decent chunk of files not to be copying to each native
sysroot for no reason.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/cmake/cmake-native_3.22.2.bb | 3 +++
 1 file changed, 3 insertions(+)

Patch

diff --git a/meta/recipes-devtools/cmake/cmake-native_3.22.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.22.2.bb
index 335097d3872..8293fe5e561 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.22.2.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.22.2.bb
@@ -46,6 +46,9 @@  do_install() {
 	install -m 644 ${WORKDIR}/OEToolchainConfig.cmake ${D}${datadir}/cmake/
 	mkdir -p ${D}${base_prefix}/environment-setup.d
 	install -m 644 ${WORKDIR}/environment.d-cmake.sh ${D}${base_prefix}/environment-setup.d/cmake.sh
+
+	# Help docs create tons of files in the native sysroot and aren't needed there
+	rm -rf ${D}${datadir}/cmake-*/Help
 }
 
 do_compile[progress] = "percent"