python3-native: Drop opt-1 and opt-2 pyc files

Message ID 20220303142837.330815-1-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit fd66de439273b245c1d0bcfb32f2c847e3cddd6b
Headers show
Series python3-native: Drop opt-1 and opt-2 pyc files | expand

Commit Message

Richard Purdie March 3, 2022, 2:28 p.m. UTC
There are over 3,000 of these in python3-native (of 8,000+ files total) and
copying them to sysroots all the time seems pointless, particularly since
they're only used if python is run with the -O or -OO parameters.

Get rid of them and save the overhead. This is particularly pronounced in
builds using the api-documentation distro feature.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/recipes-devtools/python/python3_3.10.2.bb | 5 +++++
 1 file changed, 5 insertions(+)

Patch

diff --git a/meta/recipes-devtools/python/python3_3.10.2.bb b/meta/recipes-devtools/python/python3_3.10.2.bb
index 429839b6226..b28aa6505a0 100644
--- a/meta/recipes-devtools/python/python3_3.10.2.bb
+++ b/meta/recipes-devtools/python/python3_3.10.2.bb
@@ -152,6 +152,11 @@  do_install:append:class-native() {
         # (these often end up too long for the #! parser in the kernel as the
         # buffer is 128 bytes long).
         ln -s python3-native/python3 ${D}${bindir}/nativepython3
+
+        # Remove the opt-1.pyc and opt-2.pyc files. There are over 3,000 of them
+        # and the overhead in each recipe-sysroot-native isn't worth it, particularly
+        # when they're only used for python called with -O or -OO.
+        find ${D} -name *opt-*.pyc -delete
 }
 
 do_install:append() {