glslang/spirv: synchronize with the rest of vulkan items

Message ID 20220303101315.1664127-1-alex@linutronix.de
State Accepted, archived
Commit 2961d94f1c2ca43c30497ac1853feba58b09d730
Headers show
Series glslang/spirv: synchronize with the rest of vulkan items | expand

Commit Message

Alexander Kanavin March 3, 2022, 10:13 a.m. UTC
These components are now versioned in sync with vulkan releases:
https://github.com/KhronosGroup/SPIRV-Headers/issues/252
https://github.com/KhronosGroup/SPIRV-Headers/issues/266

"We'll continue tagging the repos contributing with SDK releases, as
that is when all the testing of the various projects is performed
together."

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 .../glslang/{glslang_11.8.0.bb => glslang_1.3.204.0.bb}    | 5 +++--
 .../{spirv-headers_1.5.4.bb => spirv-headers_1.3.204.0.bb} | 4 ++--
 .../{spirv-tools_2022.1.bb => spirv-tools_1.3.204.0.bb}    | 7 ++++---
 3 files changed, 9 insertions(+), 7 deletions(-)
 rename meta/recipes-graphics/glslang/{glslang_11.8.0.bb => glslang_1.3.204.0.bb} (90%)
 rename meta/recipes-graphics/spir/{spirv-headers_1.5.4.bb => spirv-headers_1.3.204.0.bb} (88%)
 rename meta/recipes-graphics/spir/{spirv-tools_2022.1.bb => spirv-tools_1.3.204.0.bb} (89%)

Patch

diff --git a/meta/recipes-graphics/glslang/glslang_11.8.0.bb b/meta/recipes-graphics/glslang/glslang_1.3.204.0.bb
similarity index 90%
rename from meta/recipes-graphics/glslang/glslang_11.8.0.bb
rename to meta/recipes-graphics/glslang/glslang_1.3.204.0.bb
index a77d8bdf88..2af406212f 100644
--- a/meta/recipes-graphics/glslang/glslang_11.8.0.bb
+++ b/meta/recipes-graphics/glslang/glslang_1.3.204.0.bb
@@ -8,10 +8,11 @@  HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
 LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
 
-SRCREV = "c34bb3b6c55f6ab084124ad964be95a699700d34"
+SRCREV = "2742e959347ae2fac58acd0d022c92a0ff1f24bf"
 SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=master \
            file://0001-generate-glslang-pkg-config.patch"
-UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
 
 inherit cmake python3native
diff --git a/meta/recipes-graphics/spir/spirv-headers_1.5.4.bb b/meta/recipes-graphics/spir/spirv-headers_1.3.204.0.bb
similarity index 88%
rename from meta/recipes-graphics/spir/spirv-headers_1.5.4.bb
rename to meta/recipes-graphics/spir/spirv-headers_1.3.204.0.bb
index 3144b1eb42..72416b441f 100644
--- a/meta/recipes-graphics/spir/spirv-headers_1.5.4.bb
+++ b/meta/recipes-graphics/spir/spirv-headers_1.3.204.0.bb
@@ -9,9 +9,9 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=c938b85bceb8fb26c1a807f28a52ae2d"
 
 SRCREV = "b42ba6d92faf6b4938e6f22ddd186dbdacc98d78"
 SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=master"
-UPSTREAM_CHECK_GITTAGREGEX = "^(?P<pver>\d+(\.\d+)+)$"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
-PV .= "+git${SRCPV}"
 
 inherit cmake
 
diff --git a/meta/recipes-graphics/spir/spirv-tools_2022.1.bb b/meta/recipes-graphics/spir/spirv-tools_1.3.204.0.bb
similarity index 89%
rename from meta/recipes-graphics/spir/spirv-tools_2022.1.bb
rename to meta/recipes-graphics/spir/spirv-tools_1.3.204.0.bb
index 24142a4fe0..dc78073717 100644
--- a/meta/recipes-graphics/spir/spirv-tools_2022.1.bb
+++ b/meta/recipes-graphics/spir/spirv-tools_1.3.204.0.bb
@@ -7,9 +7,10 @@  SECTION = "graphics"
 LICENSE  = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-SRCREV = "b1877de5cd776117050bd42f08d04b52bce16099"
-SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=master;protocol=https"
-UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
+SRCREV = "45dd184c790d6bfc78a5a74a10c37e888b1823fa"
+SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=stable;protocol=https"
+PE = "1"
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
 S = "${WORKDIR}/git"
 
 inherit cmake python3native