systemd: fix DeprecationWarning about regexps

Message ID 20220220084743.166080-1-Martin.Jansa@gmail.com
State Accepted, archived
Commit 65ddc0f68fc2e6e8fd38ac48fd18e8099b52ec1b
Headers show
Series systemd: fix DeprecationWarning about regexps | expand

Commit Message

Martin Jansa Feb. 20, 2022, 8:47 a.m. UTC
* fixes:
  oe-core/meta/classes/package.bbclass:1342: DeprecationWarning: invalid escape sequence \.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta/recipes-core/systemd/systemd_250.3.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-core/systemd/systemd_250.3.bb b/meta/recipes-core/systemd/systemd_250.3.bb
index 0fe5fb7976..9121333f56 100644
--- a/meta/recipes-core/systemd/systemd_250.3.bb
+++ b/meta/recipes-core/systemd/systemd_250.3.bb
@@ -352,7 +352,7 @@  do_install() {
 
 python populate_packages:prepend (){
     systemdlibdir = d.getVar("rootlibdir")
-    do_split_packages(d, systemdlibdir, '^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True)
+    do_split_packages(d, systemdlibdir, r'^lib(.*)\.so\.*', 'lib%s', 'Systemd %s library', extra_depends='', allow_links=True)
 }
 PACKAGES_DYNAMIC += "^lib(udev|systemd|nss).*"