[1/2] opensbi: Upgrade to 1.0

Message ID 20220214233739.3219186-1-raj.khem@gmail.com
State Accepted, archived
Commit c48b57aa68149f5bdca80cadbf5b426c209ca94e
Headers show
Series [1/2] opensbi: Upgrade to 1.0 | expand

Commit Message

Khem Raj Feb. 14, 2022, 11:37 p.m. UTC
Drop OE specific patch to shunt march/mabi
this seems to work fine now.

unset CLANG_TARGET so it can compile with OE produced clang toolchain
which provides --target itself

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Alistair Francis <alistair.francis@wdc.com>
---
 ...Makefile-Don-t-specify-mabi-or-march.patch | 36 -------------------
 .../{opensbi_0.9.bb => opensbi_1.0.bb}        |  5 ++-
 2 files changed, 2 insertions(+), 39 deletions(-)
 delete mode 100644 meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch
 rename meta/recipes-bsp/opensbi/{opensbi_0.9.bb => opensbi_1.0.bb} (91%)

Comments

Alistair Francis Feb. 15, 2022, 10:27 p.m. UTC | #1
On Tue, Feb 15, 2022 at 9:37 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> Drop OE specific patch to shunt march/mabi
> this seems to work fine now.
>
> unset CLANG_TARGET so it can compile with OE produced clang toolchain
> which provides --target itself
>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Alistair Francis <alistair.francis@wdc.com>

Reviewed-by: Alistair Francis <alistair.francis@wdc.com>

Alistair

> ---
>  ...Makefile-Don-t-specify-mabi-or-march.patch | 36 -------------------
>  .../{opensbi_0.9.bb => opensbi_1.0.bb}        |  5 ++-
>  2 files changed, 2 insertions(+), 39 deletions(-)
>  delete mode 100644 meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch
>  rename meta/recipes-bsp/opensbi/{opensbi_0.9.bb => opensbi_1.0.bb} (91%)
>
> diff --git a/meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch b/meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch
> deleted file mode 100644
> index d2a8048e87e..00000000000
> --- a/meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch
> +++ /dev/null
> @@ -1,36 +0,0 @@
> -From fe9860fd85e49a75bef545e5d9914070491e8002 Mon Sep 17 00:00:00 2001
> -From: Alistair Francis <alistair.francis@wdc.com>
> -Date: Fri, 15 Feb 2019 14:57:41 -0800
> -Subject: [PATCH] Makefile: Don't specify mabi or march
> -
> -To avoid
> -    can't link double-float modules with soft-float modules
> -errors when building 32-bit openSBI don't specify mabi or march.
> -
> -Upstream-Status: Inappropriate [Fixes a 32-bit OE flow bug]
> -Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
> -
> ----
> - Makefile | 2 --
> - 1 file changed, 2 deletions(-)
> -
> -diff --git a/Makefile b/Makefile
> -index ccf8ea3..69e5b38 100644
> ---- a/Makefile
> -+++ b/Makefile
> -@@ -169,7 +169,6 @@ GENFLAGS   +=      $(firmware-genflags-y)
> - CFLAGS                =       -g -Wall -Werror -ffreestanding -nostdlib -fno-strict-aliasing -O2
> - CFLAGS                +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
> - CFLAGS                +=      -mno-save-restore -mstrict-align
> --CFLAGS                +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
> - CFLAGS                +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
> - CFLAGS                +=      $(GENFLAGS)
> - CFLAGS                +=      $(platform-cflags-y)
> -@@ -183,7 +182,6 @@ CPPFLAGS   +=      $(firmware-cppflags-y)
> - ASFLAGS               =       -g -Wall -nostdlib -D__ASSEMBLY__
> - ASFLAGS               +=      -fno-omit-frame-pointer -fno-optimize-sibling-calls
> - ASFLAGS               +=      -mno-save-restore -mstrict-align
> --ASFLAGS               +=      -mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
> - ASFLAGS               +=      -mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
> - ASFLAGS               +=      $(GENFLAGS)
> - ASFLAGS               +=      $(platform-asflags-y)
> diff --git a/meta/recipes-bsp/opensbi/opensbi_0.9.bb b/meta/recipes-bsp/opensbi/opensbi_1.0.bb
> similarity index 91%
> rename from meta/recipes-bsp/opensbi/opensbi_0.9.bb
> rename to meta/recipes-bsp/opensbi/opensbi_1.0.bb
> index 1956fbf9ffc..8430f62543a 100644
> --- a/meta/recipes-bsp/opensbi/opensbi_0.9.bb
> +++ b/meta/recipes-bsp/opensbi/opensbi_1.0.bb
> @@ -8,14 +8,13 @@ require opensbi-payloads.inc
>
>  inherit autotools-brokensep deploy
>
> -SRCREV = "234ed8e427f4d92903123199f6590d144e0d9351"
> +SRCREV = "ce4c0188d96b2c20c2e08d24646a5e517fe15a4b"
>  SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https \
> -           file://0001-Makefile-Don-t-specify-mabi-or-march.patch \
>            "
>
>  S = "${WORKDIR}/git"
>
> -EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n"
> +EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
>  # If RISCV_SBI_PAYLOAD is set then include it as a payload
>  EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
>  EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"
> --
> 2.35.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#161733): https://lists.openembedded.org/g/openembedded-core/message/161733
> Mute This Topic: https://lists.openembedded.org/mt/89150183/3619028
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alistair23@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch b/meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch
deleted file mode 100644
index d2a8048e87e..00000000000
--- a/meta/recipes-bsp/opensbi/files/0001-Makefile-Don-t-specify-mabi-or-march.patch
+++ /dev/null
@@ -1,36 +0,0 @@ 
-From fe9860fd85e49a75bef545e5d9914070491e8002 Mon Sep 17 00:00:00 2001
-From: Alistair Francis <alistair.francis@wdc.com>
-Date: Fri, 15 Feb 2019 14:57:41 -0800
-Subject: [PATCH] Makefile: Don't specify mabi or march
-
-To avoid
-    can't link double-float modules with soft-float modules
-errors when building 32-bit openSBI don't specify mabi or march.
-
-Upstream-Status: Inappropriate [Fixes a 32-bit OE flow bug]
-Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
-
----
- Makefile | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index ccf8ea3..69e5b38 100644
---- a/Makefile
-+++ b/Makefile
-@@ -169,7 +169,6 @@ GENFLAGS	+=	$(firmware-genflags-y)
- CFLAGS		=	-g -Wall -Werror -ffreestanding -nostdlib -fno-strict-aliasing -O2
- CFLAGS		+=	-fno-omit-frame-pointer -fno-optimize-sibling-calls
- CFLAGS		+=	-mno-save-restore -mstrict-align
--CFLAGS		+=	-mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
- CFLAGS		+=	-mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
- CFLAGS		+=	$(GENFLAGS)
- CFLAGS		+=	$(platform-cflags-y)
-@@ -183,7 +182,6 @@ CPPFLAGS	+=	$(firmware-cppflags-y)
- ASFLAGS		=	-g -Wall -nostdlib -D__ASSEMBLY__
- ASFLAGS		+=	-fno-omit-frame-pointer -fno-optimize-sibling-calls
- ASFLAGS		+=	-mno-save-restore -mstrict-align
--ASFLAGS		+=	-mabi=$(PLATFORM_RISCV_ABI) -march=$(PLATFORM_RISCV_ISA)
- ASFLAGS		+=	-mcmodel=$(PLATFORM_RISCV_CODE_MODEL)
- ASFLAGS		+=	$(GENFLAGS)
- ASFLAGS		+=	$(platform-asflags-y)
diff --git a/meta/recipes-bsp/opensbi/opensbi_0.9.bb b/meta/recipes-bsp/opensbi/opensbi_1.0.bb
similarity index 91%
rename from meta/recipes-bsp/opensbi/opensbi_0.9.bb
rename to meta/recipes-bsp/opensbi/opensbi_1.0.bb
index 1956fbf9ffc..8430f62543a 100644
--- a/meta/recipes-bsp/opensbi/opensbi_0.9.bb
+++ b/meta/recipes-bsp/opensbi/opensbi_1.0.bb
@@ -8,14 +8,13 @@  require opensbi-payloads.inc
 
 inherit autotools-brokensep deploy
 
-SRCREV = "234ed8e427f4d92903123199f6590d144e0d9351"
+SRCREV = "ce4c0188d96b2c20c2e08d24646a5e517fe15a4b"
 SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https \
-           file://0001-Makefile-Don-t-specify-mabi-or-march.patch \
           "
 
 S = "${WORKDIR}/git"
 
-EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n"
+EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=n CLANG_TARGET= "
 # If RISCV_SBI_PAYLOAD is set then include it as a payload
 EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"
 EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_fdt(d)}"