libpcap: Disable DPDK explicitly

Message ID 20220210204919.3029824-1-sean.anderson@seco.com
State Accepted, archived
Commit be5442f065da40b41d3cd60793341e22654f2681
Headers show
Series libpcap: Disable DPDK explicitly | expand

Commit Message

Sean Anderson Feb. 10, 2022, 8:49 p.m. UTC
libpcap looks for DPDK in the same way it looks for DAG. This can poison
the build even if it doesn't find anything. Explicitly disable dpdk.

Signed-off-by: Sean Anderson <sean.anderson@seco.com>
---

 meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Sean Anderson April 5, 2022, 2:53 p.m. UTC | #1
On 2/10/22 3:49 PM, Sean Anderson wrote:
> libpcap looks for DPDK in the same way it looks for DAG. This can poison
> the build even if it doesn't find anything. Explicitly disable dpdk.
> 
> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
> ---
> 
>  meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> index 9a8c46e0ef..dbe2fd8157 100644
> --- a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> +++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> @@ -19,10 +19,11 @@ BINCONFIG = "${bindir}/pcap-config"
>  
>  # Explicitly disable dag support. We don't have recipe for it and if enabled here,
>  # configure script poisons the include dirs with /usr/local/include even when the
> -# support hasn't been detected.
> +# support hasn't been detected. Do the same thing for DPDK.
>  EXTRA_OECONF = " \
>                   --with-pcap=linux \
>                   --without-dag \
> +                 --without-dpdk \
>                   "
>  EXTRA_AUTORECONF += "--exclude=aclocal"
>  
> 

ping?

--Sean
Mittal, Anuj April 5, 2022, 3:02 p.m. UTC | #2
On Thu, 2022-02-10 at 15:49 -0500, Sean Anderson via
lists.openembedded.org wrote:
> libpcap looks for DPDK in the same way it looks for DAG. This can
> poison
> the build even if it doesn't find anything. Explicitly disable dpdk.
> 
> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
> ---
> 
>  meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> index 9a8c46e0ef..dbe2fd8157 100644
> --- a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> +++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> @@ -19,10 +19,11 @@ BINCONFIG = "${bindir}/pcap-config"
>  
>  # Explicitly disable dag support. We don't have recipe for it and if
> enabled here,
>  # configure script poisons the include dirs with /usr/local/include
> even when the
> -# support hasn't been detected.
> +# support hasn't been detected. Do the same thing for DPDK.
>  EXTRA_OECONF = " \
>                   --with-pcap=linux \
>                   --without-dag \
> +                 --without-dpdk \
>                   "

Can this be converted to a PACKAGECONFIG instead? There is a DPDK
recipe in a separate layer so it might be useful for someone including
that layer.

Thanks,

Anuj
Sean Anderson April 5, 2022, 3:18 p.m. UTC | #3
On 4/5/22 11:02 AM, Mittal, Anuj wrote:
> [You don't often get email from anuj.mittal@intel.com. Learn why this is important at http://aka.ms/LearnAboutSenderIdentification.]
> 
> On Thu, 2022-02-10 at 15:49 -0500, Sean Anderson via
> lists.openembedded.org wrote:
>> libpcap looks for DPDK in the same way it looks for DAG. This can
>> poison
>> the build even if it doesn't find anything. Explicitly disable dpdk.
>>
>> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
>> ---
>>
>>  meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb | 3 ++-
>>  1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> index 9a8c46e0ef..dbe2fd8157 100644
>> --- a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> +++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> @@ -19,10 +19,11 @@ BINCONFIG = "${bindir}/pcap-config"
>>
>>  # Explicitly disable dag support. We don't have recipe for it and if
>> enabled here,
>>  # configure script poisons the include dirs with /usr/local/include
>> even when the
>> -# support hasn't been detected.
>> +# support hasn't been detected. Do the same thing for DPDK.
>>  EXTRA_OECONF = " \
>>                   --with-pcap=linux \
>>                   --without-dag \
>> +                 --without-dpdk \
>>                   "
> 
> Can this be converted to a PACKAGECONFIG instead? There is a DPDK
> recipe in a separate layer so it might be useful for someone including
> that layer.

There's no distro feature for dpdk. How would we detect if it is enabled?
Additionally, the configure script has hard-coded paths to
/usr/local/include. I think this really needs to be addressed upstream
before we could actually support dpdk.

--Sean
Sean Anderson April 5, 2022, 4:18 p.m. UTC | #4
On 4/5/22 11:02 AM, Mittal, Anuj wrote:
> On Thu, 2022-02-10 at 15:49 -0500, Sean Anderson via
> lists.openembedded.org wrote:
>> libpcap looks for DPDK in the same way it looks for DAG. This can
>> poison
>> the build even if it doesn't find anything. Explicitly disable dpdk.
>>
>> Signed-off-by: Sean Anderson <sean.anderson@seco.com>
>> ---
>>
>>  meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb | 3 ++-
>>  1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> index 9a8c46e0ef..dbe2fd8157 100644
>> --- a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> +++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
>> @@ -19,10 +19,11 @@ BINCONFIG = "${bindir}/pcap-config"
>>
>>  # Explicitly disable dag support. We don't have recipe for it and if
>> enabled here,
>>  # configure script poisons the include dirs with /usr/local/include
>> even when the
>> -# support hasn't been detected.
>> +# support hasn't been detected. Do the same thing for DPDK.
>>  EXTRA_OECONF = " \
>>                   --with-pcap=linux \
>>                   --without-dag \
>> +                 --without-dpdk \
>>                   "

Huh, well it looks like this was already applied 

https://git.openembedded.org/openembedded-core/commit/?id=be5442f065da40b41d3cd60793341e22654f2681
Richard Purdie April 5, 2022, 4:40 p.m. UTC | #5
On Tue, 2022-04-05 at 11:18 -0400, Sean Anderson via lists.openembedded.org
wrote:
> 
> On 4/5/22 11:02 AM, Mittal, Anuj wrote:
> > [You don't often get email from anuj.mittal@intel.com. Learn why this is important at http://aka.ms/LearnAboutSenderIdentification.]
> > 
> > On Thu, 2022-02-10 at 15:49 -0500, Sean Anderson via
> > lists.openembedded.org wrote:
> > > libpcap looks for DPDK in the same way it looks for DAG. This can
> > > poison
> > > the build even if it doesn't find anything. Explicitly disable dpdk.
> > > 
> > > Signed-off-by: Sean Anderson <sean.anderson@seco.com>
> > > ---
> > > 
> > >  meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb | 3 ++-
> > >  1 file changed, 2 insertions(+), 1 deletion(-)
> > > 
> > > diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> > > b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> > > index 9a8c46e0ef..dbe2fd8157 100644
> > > --- a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> > > +++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
> > > @@ -19,10 +19,11 @@ BINCONFIG = "${bindir}/pcap-config"
> > > 
> > >  # Explicitly disable dag support. We don't have recipe for it and if
> > > enabled here,
> > >  # configure script poisons the include dirs with /usr/local/include
> > > even when the
> > > -# support hasn't been detected.
> > > +# support hasn't been detected. Do the same thing for DPDK.
> > >  EXTRA_OECONF = " \
> > >                   --with-pcap=linux \
> > >                   --without-dag \
> > > +                 --without-dpdk \
> > >                   "
> > 
> > Can this be converted to a PACKAGECONFIG instead? There is a DPDK
> > recipe in a separate layer so it might be useful for someone including
> > that layer.
> 
> There's no distro feature for dpdk. How would we detect if it is enabled?
> Additionally, the configure script has hard-coded paths to
> /usr/local/include. I think this really needs to be addressed upstream
> before we could actually support dpdk.

As you mention, the change merged. We don't need it to be a DISTRO_FEATURE in
order for it to be a PACKAGECONFIG so that is a patch we could consider. It
would need to be as a follow up patch as the original has merged now (it was a
valid/correct change in it's own right).

Cheers,

Richard

Patch

diff --git a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
index 9a8c46e0ef..dbe2fd8157 100644
--- a/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
+++ b/meta/recipes-connectivity/libpcap/libpcap_1.10.1.bb
@@ -19,10 +19,11 @@  BINCONFIG = "${bindir}/pcap-config"
 
 # Explicitly disable dag support. We don't have recipe for it and if enabled here,
 # configure script poisons the include dirs with /usr/local/include even when the
-# support hasn't been detected.
+# support hasn't been detected. Do the same thing for DPDK.
 EXTRA_OECONF = " \
                  --with-pcap=linux \
                  --without-dag \
+                 --without-dpdk \
                  "
 EXTRA_AUTORECONF += "--exclude=aclocal"