[4/5] dnf: Use renamed SKIP_RECIPE varFlag

Message ID 20220204170144.105536-5-saul.wold@windriver.com
State Accepted, archived
Commit 258662ccf5ceb027ba0e507e2a581c4ee7e9cd04
Headers show
Series Use more descriptive variable for skipping recipes | expand

Commit Message

Saul Wold Feb. 4, 2022, 5:01 p.m. UTC
This is a more descriptive variable name updated in base.bbclass

Signed-off-by: Saul Wold <saul.wold@windriver.com>
---
 meta/recipes-devtools/dnf/dnf_4.10.0.bb       | 2 +-
 meta/recipes-devtools/libdnf/libdnf_0.65.0.bb | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/meta/recipes-devtools/dnf/dnf_4.10.0.bb b/meta/recipes-devtools/dnf/dnf_4.10.0.bb
index 3fc24b132df..3f22c1d8f2e 100644
--- a/meta/recipes-devtools/dnf/dnf_4.10.0.bb
+++ b/meta/recipes-devtools/dnf/dnf_4.10.0.bb
@@ -87,4 +87,4 @@  SYSTEMD_SERVICE:${PN} = "dnf-makecache.service dnf-makecache.timer \
 "
 SYSTEMD_AUTO_ENABLE ?= "disable"
 
-PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
+SKIP_RECIPE[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
diff --git a/meta/recipes-devtools/libdnf/libdnf_0.65.0.bb b/meta/recipes-devtools/libdnf/libdnf_0.65.0.bb
index 81da04c9ca1..092ad98d4b7 100644
--- a/meta/recipes-devtools/libdnf/libdnf_0.65.0.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_0.65.0.bb
@@ -34,5 +34,5 @@  EXTRA_OECMAKE:append:class-native = " -DWITH_GIR=OFF"
 EXTRA_OECMAKE:append:class-nativesdk = " -DWITH_GIR=OFF"
 
 BBCLASSEXTEND = "native nativesdk"
-PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
+SKIP_RECIPE[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"