xwayland: Add xkbcomp runtime dependency

Message ID 20220119234852.22999-1-tom.hochstein@nxp.com
State Accepted, archived
Commit 535e6df5b5e53dd95438985dcff554cd17302837
Headers show
Series xwayland: Add xkbcomp runtime dependency | expand

Commit Message

Tom Hochstein Jan. 19, 2022, 11:48 p.m. UTC
Trying to run an xterm fails with the error:
xterm: Xt error: Can't open display: :0

Checking systemctl status weston shows an error:
Jan 19 21:24:16 imx8mq-evk weston[396]: sh: line 1: /usr/bin/xkbcomp: No such file or directory

Adding xkbcomp to the rootfs fixes these errors. Checking the history
one finds that the runtime dependency for the old xserver was
removed because it wasn't in the correct location [1], then restored
because it was still needed [2].

[1] https://github.com/openembedded/openembedded-core/commit/bdcc5e8f1286d288baf410458efc39a59b68d751
[2] https://github.com/openembedded/openembedded-core/commit/f2330ebc3071d780cbc6d1ddab5c54bfadf8fffc

Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
---
 meta/recipes-graphics/xwayland/xwayland_21.1.3.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Tom Hochstein Jan. 31, 2022, 5:51 p.m. UTC | #1
Ping.

> -----Original Message-----
> From: Tom Hochstein
> Sent: Wednesday, January 19, 2022 5:49 PM
> To: openembedded-core@lists.openembedded.org
> Cc: Tom Hochstein <tom.hochstein@nxp.com>
> Subject: [PATCH] xwayland: Add xkbcomp runtime dependency
> 
> Trying to run an xterm fails with the error:
> xterm: Xt error: Can't open display: :0
> 
> Checking systemctl status weston shows an error:
> Jan 19 21:24:16 imx8mq-evk weston[396]: sh: line 1: /usr/bin/xkbcomp: No such
> file or directory
> 
> Adding xkbcomp to the rootfs fixes these errors. Checking the history one finds
> that the runtime dependency for the old xserver was removed because it wasn't
> in the correct location [1], then restored because it was still needed [2].
> 
> [1] https://github.com/openembedded/openembedded-
> core/commit/bdcc5e8f1286d288baf410458efc39a59b68d751
> [2] https://github.com/openembedded/openembedded-
> core/commit/f2330ebc3071d780cbc6d1ddab5c54bfadf8fffc
> 
> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
> ---
>  meta/recipes-graphics/xwayland/xwayland_21.1.3.bb | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
> b/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
> index 5d083e8ada..7ea40d9486 100644
> --- a/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
> +++ b/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
> @@ -42,3 +42,4 @@ do_install:append() {
> 
>  FILES:${PN} += "${libdir}/xorg/protocol.txt"
> 
> +RDEPENDS:${PN} += "xkbcomp"
> --
> 2.17.1

Patch

diff --git a/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb b/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
index 5d083e8ada..7ea40d9486 100644
--- a/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
+++ b/meta/recipes-graphics/xwayland/xwayland_21.1.3.bb
@@ -42,3 +42,4 @@  do_install:append() {
 
 FILES:${PN} += "${libdir}/xorg/protocol.txt"
 
+RDEPENDS:${PN} += "xkbcomp"