perl: Enable threading

Message ID 20211230212344.94913-1-saul.wold@windriver.com
State Accepted, archived
Commit b9fd7cd319a1d8f0ddf5ea60710b015e9afb588c
Headers show
Series perl: Enable threading | expand

Commit Message

Saul Wold Dec. 30, 2021, 9:23 p.m. UTC
When the tranisiton to perl-cross occured, the threading define
seems to have been missed.  The perl tests for threading where
simply skipped, so there was no direct failures.  This was verified
by running perl ptest before and after the change to see PASS vs SKIP
results of threaded related tests.

Signed-off-by: Saul Wold <saul.wold@windriver.com>
---
 meta/recipes-devtools/perl/perl_5.34.0.bb | 1 +
 1 file changed, 1 insertion(+)

Comments

Khem Raj Jan. 6, 2022, 6:22 p.m. UTC | #1
On Thu, Dec 30, 2021 at 1:24 PM Saul Wold <Saul.Wold@windriver.com> wrote:
>
> When the tranisiton to perl-cross occured, the threading define
> seems to have been missed.  The perl tests for threading where
> simply skipped, so there was no direct failures.  This was verified
> by running perl ptest before and after the change to see PASS vs SKIP
> results of threaded related tests.
>

Do we need this for perl-native too ? I am seeing failures like below

https://errors.yoctoproject.org/Errors/Details/621556/
https://errors.yoctoproject.org/Errors/Details/621555/

can you take a look ?

> Signed-off-by: Saul Wold <saul.wold@windriver.com>
> ---
>  meta/recipes-devtools/perl/perl_5.34.0.bb | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
> index a6ae80f07e1..3306a093692 100644
> --- a/meta/recipes-devtools/perl/perl_5.34.0.bb
> +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
> @@ -53,6 +53,7 @@ do_configure:class-target() {
>      ./configure --prefix=${prefix} --libdir=${libdir} \
>      --target=${TARGET_SYS} \
>      -Duseshrplib \
> +    -Dusethreads \
>      -Dsoname=libperl.so.5 \
>      -Dvendorprefix=${prefix} \
>      -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
> --
> 2.31.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#160066): https://lists.openembedded.org/g/openembedded-core/message/160066
> Mute This Topic: https://lists.openembedded.org/mt/88042607/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Saul Wold Jan. 6, 2022, 6:39 p.m. UTC | #2
On 1/6/22 10:22, Khem Raj wrote:
> On Thu, Dec 30, 2021 at 1:24 PM Saul Wold <Saul.Wold@windriver.com> wrote:
>>
>> When the tranisiton to perl-cross occured, the threading define
>> seems to have been missed.  The perl tests for threading where
>> simply skipped, so there was no direct failures.  This was verified
>> by running perl ptest before and after the change to see PASS vs SKIP
>> results of threaded related tests.
>>
> 
> Do we need this for perl-native too ? I am seeing failures like below
> 
> https://errors.yoctoproject.org/Errors/Details/621556/
> https://errors.yoctoproject.org/Errors/Details/621555/
> 
> can you take a look ?
> 
Yes, I am looking into it.  RP mentioned it earlier today.

Yes, I guess I just enabled for the target and not native or nativesdk, 
building and testing now.


Sau!

>> Signed-off-by: Saul Wold <saul.wold@windriver.com>
>> ---
>>   meta/recipes-devtools/perl/perl_5.34.0.bb | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
>> index a6ae80f07e1..3306a093692 100644
>> --- a/meta/recipes-devtools/perl/perl_5.34.0.bb
>> +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
>> @@ -53,6 +53,7 @@ do_configure:class-target() {
>>       ./configure --prefix=${prefix} --libdir=${libdir} \
>>       --target=${TARGET_SYS} \
>>       -Duseshrplib \
>> +    -Dusethreads \
>>       -Dsoname=libperl.so.5 \
>>       -Dvendorprefix=${prefix} \
>>       -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \
>> --
>> 2.31.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#160066): https://lists.openembedded.org/g/openembedded-core/message/160066
>> Mute This Topic: https://lists.openembedded.org/mt/88042607/1997914
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>

Patch

diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb
index a6ae80f07e1..3306a093692 100644
--- a/meta/recipes-devtools/perl/perl_5.34.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.0.bb
@@ -53,6 +53,7 @@  do_configure:class-target() {
     ./configure --prefix=${prefix} --libdir=${libdir} \
     --target=${TARGET_SYS} \
     -Duseshrplib \
+    -Dusethreads \
     -Dsoname=libperl.so.5 \
     -Dvendorprefix=${prefix} \
     -Darchlibexp=${STAGING_LIBDIR}/perl5/${PV}/${TARGET_ARCH}-linux \