[3/3] kmod: expand compression PACKAGECONFIGs

Message ID 20211220182635.885262-3-ross.burton@arm.com
State Accepted, archived
Commit 6dd6184f01d79ebd26347a6006f92a5b5906ee3e
Headers show
Series [1/3] kmod: remove obsolete ac_pwd manipulation | expand

Commit Message

Ross Burton Dec. 20, 2021, 6:26 p.m. UTC
Turn the explicitly enabled zlib support into an enabled by default
PACKAGECONFIG, and add Zstd support (disabled by default).

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-kernel/kmod/kmod_29.bb | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Patch

diff --git a/meta/recipes-kernel/kmod/kmod_29.bb b/meta/recipes-kernel/kmod/kmod_29.bb
index 904a17d9d0..9ac5214df6 100644
--- a/meta/recipes-kernel/kmod/kmod_29.bb
+++ b/meta/recipes-kernel/kmod/kmod_29.bb
@@ -24,17 +24,19 @@  SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git;branch=master
 
 S = "${WORKDIR}/git"
 
-EXTRA_OECONF += "--enable-tools --with-zlib"
+EXTRA_OECONF += "--enable-tools"
 
+PACKAGECONFIG ??= "zlib"
 PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
 PACKAGECONFIG[logging] = " --enable-logging,--disable-logging"
 PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
-PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz"
 PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
+PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz"
+PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
+PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
 
 GTKDOC_DOCDIR = "${S}/libkmod/docs"
 
-DEPENDS += "zlib"
 PROVIDES += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
 RPROVIDES:${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"
 RCONFLICTS:${PN} += "module-init-tools-insmod-static module-init-tools-depmod module-init-tools"