[hardknott] python3-pyelftools: Depend on debugger, pprint

Message ID 20211217000952.7580-1-chaitanya.vadrevu@ni.com
State Accepted, archived
Commit 66211faf4724b2c88eb4595e41fe98f5da96c3ee
Headers show
Series [hardknott] python3-pyelftools: Depend on debugger, pprint | expand

Commit Message

Chaitanya Vadrevu Dec. 17, 2021, 12:09 a.m. UTC
python3-pyelftools uses python3-debugger, python3-pprint.
So add dependencies on these packages.

Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
---
 meta/recipes-devtools/python/python3-pyelftools_0.27.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Chaitanya Vadrevu Jan. 10, 2022, 5:45 p.m. UTC | #1
It appears that on the hardknott branch, instead of this patch a corresponding patch from master branch was cherry-picked.

The override separator is different between master and hardknott branches – on hardknott it should be “RDEPENDS_” instead of “RDEPENDS:”. This patch uses the correct separator for hardknott.

Can the cherry-picked commit (66211fa) be reverted on hardknott and this patch applied instead?

Thanks,
Chaitanya

From: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
Date: Thursday, December 16, 2021 at 6:10 PM
To: openembedded-core@lists.openembedded.org <openembedded-core@lists.openembedded.org>
Cc: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
Subject: [hardknott][PATCH] python3-pyelftools: Depend on debugger, pprint
python3-pyelftools uses python3-debugger, python3-pprint.
So add dependencies on these packages.

Signed-off-by: Chaitanya Vadrevu <chaitanya.vadrevu@ni.com>
---
 meta/recipes-devtools/python/python3-pyelftools_0.27.bb | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
index 0cfd99504b..f8b9d420a5 100644
--- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
+++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
@@ -11,3 +11,5 @@ PYPI_PACKAGE = "pyelftools"
 inherit pypi setuptools3

 BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"
--
2.17.1


INTERNAL - NI CONFIDENTIAL

Patch

diff --git a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
index 0cfd99504b..f8b9d420a5 100644
--- a/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
+++ b/meta/recipes-devtools/python/python3-pyelftools_0.27.bb
@@ -11,3 +11,5 @@  PYPI_PACKAGE = "pyelftools"
 inherit pypi setuptools3
 
 BBCLASSEXTEND = "native"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-debugger ${PYTHON_PN}-pprint"