libical: upgrade to 3.0.12

Message ID 20211213174601.643090-1-ross.burton@arm.com
State Accepted, archived
Commit dc91910a5ee56af5dee495fafcabab4042431cae
Headers show
Series libical: upgrade to 3.0.12 | expand

Commit Message

Ross Burton Dec. 13, 2021, 5:46 p.m. UTC
Disable tests to save some build time as we can't install them.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../libical/{libical_3.0.11.bb => libical_3.0.12.bb} | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)
 rename meta/recipes-support/libical/{libical_3.0.11.bb => libical_3.0.12.bb} (83%)

Patch

diff --git a/meta/recipes-support/libical/libical_3.0.11.bb b/meta/recipes-support/libical/libical_3.0.12.bb
similarity index 83%
rename from meta/recipes-support/libical/libical_3.0.11.bb
rename to meta/recipes-support/libical/libical_3.0.12.bb
index b16081e9e28..b2b2211b9b4 100644
--- a/meta/recipes-support/libical/libical_3.0.11.bb
+++ b/meta/recipes-support/libical/libical_3.0.12.bb
@@ -12,14 +12,13 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
                     "
 SECTION = "libs"
 
-SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
-"
-SRC_URI[sha256sum] = "1e6c5e10c5a48f7a40c68958055f0e2759d9ab3563aca17273fe35a5df7dbbf1"
+SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "35095a4cc1a061a3de0f332c2dc728226cf127fa0baa818e9f8856cee6d35830"
 UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
 
 inherit cmake pkgconfig
 
-DEPENDS:append:class-target = " libical-native"
+DEPENDS += "libical-native"
 
 PACKAGECONFIG ??= "icu glib"
 PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
@@ -29,13 +28,16 @@  PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
 
 # No need to use perl-native, the host perl is sufficient.
 EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
+# Disable the test suite as we can't install it
+EXTRA_OECMAKE += "-DLIBICAL_BUILD_TESTING=false"
 # doc build fails with linker error (??) for libical-glib so disable it
 EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
 
+# Tell the cross-libical where the tool it needs to build is
 EXTRA_OECMAKE:append:class-target = " -DIMPORT_ICAL_GLIB_SRC_GENERATOR=${STAGING_LIBDIR_NATIVE}/cmake/LibIcal/IcalGlibSrcGenerator.cmake"
 
 do_install:append () {
-    # Remove build host references
+    # Remove build host references (https://github.com/libical/libical/issues/532)
     sed -i \
        -e 's,${STAGING_LIBDIR},${libdir},g' \
        -e 's,${STAGING_INCDIR},${includedir},g' \