[05/26] python3: drop unneeded multiprocessing module patch

Message ID 20211204071323.2480163-5-alex@linutronix.de
State Accepted, archived
Commit 2eabd3b611f4afa5eafa4490b6b0ef7578b742de
Headers show
Series [01/26] insane.bbclass: do not hardcode oe-core path in upstream-status check | expand

Commit Message

Alexander Kanavin Dec. 4, 2021, 7:13 a.m. UTC
I ran the reproducing sequence on qemux86, and it went fine:

root@qemux86:~# python3
Python 3.10.0 (default, Oct  4 2021, 17:55:55) [GCC 11.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import multiprocessing
>>> pool_sema = multiprocessing.BoundedSemaphore(value=1)
>>> pool_sema.acquire()
True
>>> pool_sema.release()
>>>

Additionally AB testing revealed no issues, and the description isn't entirely
clear about where and how the problem occurs, so I can't submit it upsream
without having that understanding and how to demonstrate the problem.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...ssing-libraries-to-Extension-for-mul.patch | 70 -------------------
 .../recipes-devtools/python/python3_3.10.0.bb |  1 -
 2 files changed, 71 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3/0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch

Comments

Richard Purdie Dec. 6, 2021, 11:07 a.m. UTC | #1
On Sat, 2021-12-04 at 08:13 +0100, Alexander Kanavin wrote:
> I ran the reproducing sequence on qemux86, and it went fine:
> 
> root@qemux86:~# python3
> Python 3.10.0 (default, Oct  4 2021, 17:55:55) [GCC 11.2.0] on linux
> Type "help", "copyright", "credits" or "license" for more information.
> > > > import multiprocessing
> > > > pool_sema = multiprocessing.BoundedSemaphore(value=1)
> > > > pool_sema.acquire()
> True
> > > > pool_sema.release()
> > > > 
> 
> Additionally AB testing revealed no issues, and the description isn't entirely
> clear about where and how the problem occurs, so I can't submit it upsream
> without having that understanding and how to demonstrate the problem.
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> 

There is a slightly different explanation here. libpthread was merged into libc
so this fix becomes a null-op on glibc. Not sure if musl has a separate pthread
but if so we could/should test that?

Cheers,

Richard
Khem Raj Dec. 6, 2021, 4:13 p.m. UTC | #2
On Mon, Dec 6, 2021 at 3:07 AM Richard Purdie <
richard.purdie@linuxfoundation.org> wrote:

> On Sat, 2021-12-04 at 08:13 +0100, Alexander Kanavin wrote:
> > I ran the reproducing sequence on qemux86, and it went fine:
> >
> > root@qemux86:~# python3
> > Python 3.10.0 (default, Oct  4 2021, 17:55:55) [GCC 11.2.0] on linux
> > Type "help", "copyright", "credits" or "license" for more information.
> > > > > import multiprocessing
> > > > > pool_sema = multiprocessing.BoundedSemaphore(value=1)
> > > > > pool_sema.acquire()
> > True
> > > > > pool_sema.release()
> > > > >
> >
> > Additionally AB testing revealed no issues, and the description isn't
> entirely
> > clear about where and how the problem occurs, so I can't submit it
> upsream
> > without having that understanding and how to demonstrate the problem.
> >
> > Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> >
>
> There is a slightly different explanation here. libpthread was merged into
> libc
> so this fix becomes a null-op on glibc. Not sure if musl has a separate
> pthread
> but if so we could/should test that?


Musl has always been a single shared object from day one infact glibc is
now moving in that direction so it will work fine on musl

>
>
> Cheers,
>
> Richard
>
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#159219):
> https://lists.openembedded.org/g/openembedded-core/message/159219
> Mute This Topic: https://lists.openembedded.org/mt/87494766/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Alexander Kanavin Dec. 6, 2021, 4:22 p.m. UTC | #3
On Mon, 6 Dec 2021 at 17:13, Khem Raj <raj.khem@gmail.com> wrote:

> There is a slightly different explanation here. libpthread was merged into
> libc
>
>> so this fix becomes a null-op on glibc. Not sure if musl has a separate
>> pthread
>> but if so we could/should test that?
>
>
> Musl has always been a single shared object from day one infact glibc is
> now moving in that direction so it will work fine on musl
>

Yep, I just verified this on qemux86 and qemux86-64.

Alex

Patch

diff --git a/meta/recipes-devtools/python/python3/0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch b/meta/recipes-devtools/python/python3/0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch
deleted file mode 100644
index 374433c68e..0000000000
--- a/meta/recipes-devtools/python/python3/0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch
+++ /dev/null
@@ -1,70 +0,0 @@ 
-From bad7e6a625436402a01d03021fb9ccd58bc9930f Mon Sep 17 00:00:00 2001
-From: Alexander Kanavin <alex.kanavin@gmail.com>
-Date: Thu, 9 Jan 2020 17:44:05 +0100
-Subject: [PATCH] setup.py: pass missing libraries to Extension for
- multiprocessing module
-
-In the following commit:
-...
-commit e711cafab13efc9c1fe6c5cd75826401445eb585
-Author: Benjamin Peterson <benjamin@python.org>
-Date:   Wed Jun 11 16:44:04 2008 +0000
-
-    Merged revisions 64104,64117 via svnmerge from
-    svn+ssh://pythondev@svn.python.org/python/trunk
-...
-(see diff in setup.py)
-It assigned libraries for multiprocessing module according
-the host_platform, but not pass it to Extension.
-
-In glibc, the following commit caused two definition of
-sem_getvalue are different.
-https://sourceware.org/git/?p=glibc.git;a=commit;h=042e1521c794a945edc43b5bfa7e69ad70420524
-(see diff in nptl/sem_getvalue.c for detail)
-`__new_sem_getvalue' is the latest sem_getvalue@@GLIBC_2.1
-and `__old_sem_getvalue' is to compat the old version
-sem_getvalue@GLIBC_2.0.
-
-To build python for embedded Linux systems:
-http://www.yoctoproject.org/docs/2.3.1/yocto-project-qs/yocto-project-qs.html
-If not explicitly link to library pthread (-lpthread), it will
-load glibc's sem_getvalue randomly at runtime.
-
-Such as build python on linux x86_64 host and run the python
-on linux x86_32 target. If not link library pthread, it caused
-multiprocessing bounded semaphore could not work correctly.
-...
->>> import multiprocessing
->>> pool_sema = multiprocessing.BoundedSemaphore(value=1)
->>> pool_sema.acquire()
-True
->>> pool_sema.release()
-Traceback (most recent call last):
-  File "<stdin>", line 1, in <module>
-ValueError: semaphore or lock released too many times
-...
-
-And the semaphore issue also caused multiprocessing.Queue().put() hung.
-
-Upstream-Status: Pending
-
-Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
-
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index d92face..f42bcbb 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1836,7 +1836,7 @@ class PyBuildExt(build_ext):
-             if (sysconfig.get_config_var('HAVE_SEM_OPEN') and not
-                 sysconfig.get_config_var('POSIX_SEMAPHORES_NOT_ENABLED')):
-                 multiprocessing_srcs.append('_multiprocessing/semaphore.c')
--        self.add(Extension('_multiprocessing', multiprocessing_srcs,
-+        self.add(Extension('_multiprocessing', multiprocessing_srcs, libraries=['pthread'],
-                            include_dirs=["Modules/_multiprocessing"]))
- 
-         if (not MS_WINDOWS and
diff --git a/meta/recipes-devtools/python/python3_3.10.0.bb b/meta/recipes-devtools/python/python3_3.10.0.bb
index e3300b6495..24e6c04fe9 100644
--- a/meta/recipes-devtools/python/python3_3.10.0.bb
+++ b/meta/recipes-devtools/python/python3_3.10.0.bb
@@ -25,7 +25,6 @@  SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
            file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
            file://0001-test_locale.py-correct-the-test-output-format.patch \
            file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
-           file://0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
            file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
            file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
            file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \