diff mbox series

python3-markdown: upgrade 3.5 -> 3.5.2

Message ID 1705310491-24562-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit d4396cc50ed7d73323fdef46b84ef26ab2b6a15f
Headers show
Series python3-markdown: upgrade 3.5 -> 3.5.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 15, 2024, 9:21 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-Fix type annotations for convertFile - it accepts only bytes-based buffers.
 Also remove legacy checks from Python 2
-Remove legacy import needed only in Python 2
-Fix typo that left the attribute AdmonitionProcessor.content_indent unset
-Fix edge-case crash in InlineProcessor with AtomicString.
-Fix edge-case crash in codehilite with an empty code tag.
-Improve and expand type annotations in the code base.
-Fix handling of bogus comments

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-markdown_3.5.bb => python3-markdown_3.5.2.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-markdown_3.5.bb => python3-markdown_3.5.2.bb} (81%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-markdown_3.5.bb b/meta/recipes-devtools/python/python3-markdown_3.5.2.bb
similarity index 81%
rename from meta/recipes-devtools/python/python3-markdown_3.5.bb
rename to meta/recipes-devtools/python/python3-markdown_3.5.2.bb
index 1ad3f7828d..6836c5638f 100644
--- a/meta/recipes-devtools/python/python3-markdown_3.5.bb
+++ b/meta/recipes-devtools/python/python3-markdown_3.5.2.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.md;md5=745aaad0c69c60039e638bff9ffc59ed"
 inherit pypi python_setuptools_build_meta
 
 PYPI_PACKAGE = "Markdown"
-SRC_URI[sha256sum] = "a807eb2e4778d9156c8f07876c6e4d50b5494c5665c4834f67b06459dfd877b3"
+SRC_URI[sha256sum] = "e1ac7b3dc550ee80e602e71c1d168002f062e49f1b11e26a36264dafd4df2ef8"
 
 BBCLASSEXTEND = "native nativesdk"