diff mbox series

python3-cython: upgrade 3.0.7 -> 3.0.8

Message ID 1705310236-24392-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit bedd518a2a0c2e7085f92c79236b0c0983f3d653
Headers show
Series python3-cython: upgrade 3.0.7 -> 3.0.8 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 15, 2024, 9:17 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
* Using "const" together with defined fused types could fail to compile.
* A "use after free" bug was fixed in parallel sections.
* Several types were not available as "cython.*" types in pure Python code.
* The generated code is now correct C89 again, removing some C++ style "//" comments
  and C99-style declaration-after-code code ordering.  This is still relevant for some
  ols C compilers, specifically ones that match old Python 2.7 installations.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta/recipes-devtools/python/python-cython.inc                  | 2 +-
 .../python/{python3-cython_3.0.7.bb => python3-cython_3.0.8.bb} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-cython_3.0.7.bb => python3-cython_3.0.8.bb} (100%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python-cython.inc b/meta/recipes-devtools/python/python-cython.inc
index bc1953c504..d116eb826d 100644
--- a/meta/recipes-devtools/python/python-cython.inc
+++ b/meta/recipes-devtools/python/python-cython.inc
@@ -9,7 +9,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c"
 PYPI_PACKAGE = "Cython"
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI[sha256sum] = "fb299acf3a578573c190c858d49e0cf9d75f4bc49c3f24c5a63804997ef09213"
+SRC_URI[sha256sum] = "8333423d8fd5765e7cceea3a9985dd1e0a5dfeb2734629e1a2ed2d6233d39de6"
 UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar"
 
 inherit pypi
diff --git a/meta/recipes-devtools/python/python3-cython_3.0.7.bb b/meta/recipes-devtools/python/python3-cython_3.0.8.bb
similarity index 100%
rename from meta/recipes-devtools/python/python3-cython_3.0.7.bb
rename to meta/recipes-devtools/python/python3-cython_3.0.8.bb