diff mbox series

ccache: upgrade 4.8.3 -> 4.9

Message ID 1704180049-8477-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit a237c43adc717ea92e1353ee93c29b47a52ad81a
Headers show
Series ccache: upgrade 4.8.3 -> 4.9 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 2, 2024, 7:20 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update:
===============
Upgrade to fmt 10.1.1
Upgrade to cpp-httplib 0.14.3
Upgrade to BLAKE3 1.5.0

Changelog:
 https://ccache.dev/releasenotes.html#_ccache_4_9

0001-xxhash.h-Fix-build-with-gcc-12.patch
refreshed for 4.9

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../ccache/{ccache_4.8.3.bb => ccache_4.9.bb}               | 4 ++--
 .../ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch  | 6 +++---
 2 files changed, 5 insertions(+), 5 deletions(-)
 rename meta/recipes-devtools/ccache/{ccache_4.8.3.bb => ccache_4.9.bb} (82%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/ccache/ccache_4.8.3.bb b/meta/recipes-devtools/ccache/ccache_4.9.bb
similarity index 82%
rename from meta/recipes-devtools/ccache/ccache_4.8.3.bb
rename to meta/recipes-devtools/ccache/ccache_4.9.bb
index 03372aa685..8550470e3f 100644
--- a/meta/recipes-devtools/ccache/ccache_4.8.3.bb
+++ b/meta/recipes-devtools/ccache/ccache_4.9.bb
@@ -7,14 +7,14 @@  HOMEPAGE = "http://ccache.samba.org"
 SECTION = "devel"
 
 LICENSE = "GPL-3.0-or-later"
-LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=6a6fe0ae4e57592b187ab72fa6d420ec"
+LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=11b0b581dd56bbac4f5de214d47927ca"
 
 DEPENDS = "zstd"
 
 SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
            file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
            "
-SRC_URI[sha256sum] = "d59dd569ad2bbc826c0bc335c8ebd73e78ed0f2f40ba6b30069347e63585d9ef"
+SRC_URI[sha256sum] = "866b2223d59333640f0e7a003cbb85b32d9ca3c9445bd9e3cf142942e69dd3ec"
 
 inherit cmake github-releases
 
diff --git a/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch b/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
index 67c74a1e8e..e65b830257 100644
--- a/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
+++ b/meta/recipes-devtools/ccache/files/0001-xxhash.h-Fix-build-with-gcc-12.patch
@@ -1,4 +1,4 @@ 
-From 550834a3ec2e05e379be63b084e7fa06a1723f84 Mon Sep 17 00:00:00 2001
+From d17fdacf4892a15fafb56b0890ece05b485e89fb Mon Sep 17 00:00:00 2001
 From: Mingli Yu <mingli.yu@windriver.com>
 Date: Mon, 6 Jun 2022 17:53:20 +0800
 Subject: [PATCH] xxhash.h: Fix build with gcc-12
@@ -23,10 +23,10 @@  Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/src/third_party/xxhash.h b/src/third_party/xxhash.h
-index 08ab794..c754e99 100644
+index a18e8c7..1b72307 100644
 --- a/src/third_party/xxhash.h
 +++ b/src/third_party/xxhash.h
-@@ -1501,7 +1501,7 @@ static void* XXH_memcpy(void* dest, const void* src, size_t size)
+@@ -2107,7 +2107,7 @@ static void* XXH_memcpy(void* dest, const void* src, size_t size)
  #  define XXH_NO_INLINE static
  /* enable inlining hints */
  #elif defined(__GNUC__) || defined(__clang__)