diff mbox series

python3-pyrsistent: upgrade 0.19.3 -> 0.20.0

Message ID 1698996086-30584-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 10d96b7880c81575f1b5d4b3c920229cee71c43a
Headers show
Series python3-pyrsistent: upgrade 0.19.3 -> 0.20.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Nov. 3, 2023, 7:21 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
 * Fix #245, never introduce new nodes during discard.
 * Fix #268, do not rely on well implemented __ne__ for keys in pmaps, instead do explicit inversion of equality
   comparison when checking for inequality.
 * Officially support Python 3.12.
 * Officially drop support for Python 3.7.
 * Fix #273, build more types of wheels. Thanks @jams2 for this!
 * Fix #282, add generic types to types. Thanks @lukasK9999 for this!
 * Fix #281, defaultdict can now be frozen. NB! This is a backwards incompatible fix since defaultdict was not
   previously frozen.

License-Update: Copyright year updated to 2023.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...hon3-pyrsistent_0.19.3.bb => python3-pyrsistent_0.20.0.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta/recipes-devtools/python/{python3-pyrsistent_0.19.3.bb => python3-pyrsistent_0.20.0.bb} (61%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-pyrsistent_0.19.3.bb b/meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
similarity index 61%
rename from meta/recipes-devtools/python/python3-pyrsistent_0.19.3.bb
rename to meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
index 05654c348d..9661f1474e 100644
--- a/meta/recipes-devtools/python/python3-pyrsistent_0.19.3.bb
+++ b/meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
@@ -1,9 +1,9 @@ 
 SUMMARY = "Persistent/Immutable/Functional data structures for Python"
 HOMEPAGE = "https://github.com/tobgu/pyrsistent"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=b695eb9c6e7a6fb1b1bc2d193c42776e"
+LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=f798dc4222a29fea881fa998cdf4a8c8"
 
-SRC_URI[sha256sum] = "1a2994773706bbb4995c31a97bc94f1418314923bd1048c6d964837040376440"
+SRC_URI[sha256sum] = "4c48f78f62ab596c679086084d0dd13254ae4f3d6c72a83ffdf5ebdef8f265a4"
 
 inherit pypi python_setuptools_build_meta