diff mbox series

python3-setuptools: upgrade 68.1.0 -> 68.1.2

Message ID 1693450026-28398-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 27d3e5bc7ea949c4e7691674617cf29c80b3035f
Headers show
Series python3-setuptools: upgrade 68.1.0 -> 68.1.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 31, 2023, 2:47 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

0001-conditionally-do-not-fetch-code-by-easy_install.patch
refreshed for new version.

Changelog:
-Fix editable install finder handling of nested packages, by only handling 1
 level of nesting and relying on importlib.machinery to find the remaining
 modules based on the parent package path. 

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...nditionally-do-not-fetch-code-by-easy_install.patch | 10 ++++------
 ...tuptools_68.1.0.bb => python3-setuptools_68.1.2.bb} |  2 +-
 2 files changed, 5 insertions(+), 7 deletions(-)
 rename meta/recipes-devtools/python/{python3-setuptools_68.1.0.bb => python3-setuptools_68.1.2.bb} (95%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch b/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
index 1e5ab498a4..84a9492caf 100644
--- a/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
+++ b/meta/recipes-devtools/python/python3-setuptools/0001-conditionally-do-not-fetch-code-by-easy_install.patch
@@ -1,4 +1,4 @@ 
-From 5e603da9c01ccb828a03ea3e82d15599971f794f Mon Sep 17 00:00:00 2001
+From c90cc4a07ce6d2b7128e37d811d0c6bbc4b905a6 Mon Sep 17 00:00:00 2001
 From: Hongxu Jia <hongxu.jia@windriver.com>
 Date: Tue, 17 Jul 2018 10:13:38 +0800
 Subject: [PATCH] conditionally do not fetch code by easy_install
@@ -9,15 +9,16 @@  internet by easy_install.
 Upstream-Status: Inappropriate [oe specific]
 
 Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
 ---
  setuptools/command/easy_install.py | 5 +++++
  1 file changed, 5 insertions(+)
 
 diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
-index 0b8d1159..93308060 100644
+index 8ba4f09..8ea40c5 100644
 --- a/setuptools/command/easy_install.py
 +++ b/setuptools/command/easy_install.py
-@@ -644,6 +644,11 @@ class easy_install(Command):
+@@ -676,6 +676,11 @@ class easy_install(Command):
              os.path.exists(tmpdir) and _rmtree(tmpdir)
  
      def easy_install(self, spec, deps=False):
@@ -29,6 +30,3 @@  index 0b8d1159..93308060 100644
          with self._tmpdir() as tmpdir:
              if not isinstance(spec, Requirement):
                  if URL_SCHEME(spec):
--- 
-2.41.0
-
diff --git a/meta/recipes-devtools/python/python3-setuptools_68.1.0.bb b/meta/recipes-devtools/python/python3-setuptools_68.1.2.bb
similarity index 95%
rename from meta/recipes-devtools/python/python3-setuptools_68.1.0.bb
rename to meta/recipes-devtools/python/python3-setuptools_68.1.2.bb
index e04cd1dcd0..a1e84b635c 100644
--- a/meta/recipes-devtools/python/python3-setuptools_68.1.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_68.1.2.bb
@@ -11,7 +11,7 @@  SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-e
 SRC_URI += " \
             file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch"
 
-SRC_URI[sha256sum] = "d59c97e7b774979a5ccb96388efc9eb65518004537e85d52e81eaee89ab6dd91"
+SRC_URI[sha256sum] = "3d4dfa6d95f1b101d695a6160a7626e15583af71a5f52176efa5d39a054d475d"
 
 DEPENDS += "${PYTHON_PN}"