diff mbox series

python3: upgrade 3.11.4 -> 3.11.5

Message ID 1693449493-28135-1-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 70df63c2fe59ab781152b6981caf0828ececc54e
Headers show
Series python3: upgrade 3.11.4 -> 3.11.5 | expand

Commit Message

Mingyu Wang (Fujitsu) Aug. 31, 2023, 2:38 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
============
-gh-104432: Fix potential unaligned memory access on C APIs involving returned
 sequences of char * pointers within the grp and socket modules. These were
 revealed using a -fsaniziter=alignment build on ARM macOS.
-gh-77377: Ensure that multiprocessing synchronization objects created in a fork
 context are not sent to a different process created in a spawn context.
 This changes a segfault into an actionable RuntimeError in the parent process.
-gh-106092: Fix a segmentation fault caused by a use-after-free bug in frame_dealloc when the trashcan delays the deallocation of a PyFrameObject.
-gh-106719: No longer suppress arbitrary errors in the __annotations__ getter and setter in the type and module types.
-gh-106723: Propagate frozen_modules to multiprocessing spawned process interpreters.
-gh-105979: Fix crash in _imp.get_frozen_object() due to improper exception handling.
-gh-105840: Fix possible crashes when specializing function calls with too many __defaults__.
-gh-105588: Fix an issue that could result in crashes when compiling malformed ast nodes.
-gh-105375: Fix bugs in the builtins module where exceptions could end up being overwritten.
-gh-105375: Fix bug in the compiler where an exception could end up being overwritten.
-gh-105375: Improve error handling in PyUnicode_BuildEncodingMap() where an exception could end up being overwritten.
-gh-105235: Prevent out-of-bounds memory access during mmap.find() calls.
--gh-101006: Improve error handling when read marshal data.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3_3.11.4.bb => python3_3.11.5.bb}             | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3_3.11.4.bb => python3_3.11.5.bb} (99%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3_3.11.4.bb b/meta/recipes-devtools/python/python3_3.11.5.bb
similarity index 99%
rename from meta/recipes-devtools/python/python3_3.11.4.bb
rename to meta/recipes-devtools/python/python3_3.11.5.bb
index 8fd1382caa..416b5f174d 100644
--- a/meta/recipes-devtools/python/python3_3.11.4.bb
+++ b/meta/recipes-devtools/python/python3_3.11.5.bb
@@ -39,7 +39,7 @@  SRC_URI:append:class-native = " \
            file://12-distutils-prefix-is-inside-staging-area.patch \
            file://0001-Don-t-search-system-for-headers-libraries.patch \
            "
-SRC_URI[sha256sum] = "2f0e409df2ab57aa9fc4cbddfb976af44e4e55bf6f619eee6bc5c2297264a7f6"
+SRC_URI[sha256sum] = "85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f"
 
 # exclude pre-releases for both python 2.x and 3.x
 UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"