diff mbox series

gettext: upgrade 0.21.1 -> 0.22

Message ID 1687850250-20040-15-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series gettext: upgrade 0.21.1 -> 0.22 | expand

Commit Message

Mingyu Wang (Fujitsu) June 27, 2023, 7:17 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
* PO file format:
  - When a #: line contains references to file names that contain spaces,
    these file names are surrounded by Unicode characters U+2068 and U+2069.
    This makes it possible to parse such references correctly.

* Improvements for maintainers:
  - The AM_GNU_GETTEXT macro now defines two variables localedir_c and
    localedir_c_make, that can be used in C code or in Makefiles,
    respectively, for representing the value of the --localedir configure
    option.

* Programming languages support:
  - C, C++:
    o xgettext now supports gettext-like functions that take wide strings
      (of type 'const wchar_t *', 'const char16_t *', or 'const char32_t *')
      as arguments.
    o xgettext now recognizes numbers with digit separators, as defined by
      ISO C 23, as tokens.
    o xgettext and msgfmt now recognize the format string directive %b
      (for binary integer output, as defined by ISO C 23) in format strings.
    o xgettext and msgfmt now recognize the argument size specifiers
      w8, w16, w32, w64, wf8, wf16, wf32, wf64 (as defined by ISO C 23)
      in format strings.
    o xgettext and msgfmt now recognize C++ format strings, as defined by
      ISO C++ 20.  They are marked as 'c++-format' in POT and PO files.
      A new example has been added, 'hello-c++20', that illustrates how
      to use these format strings with gettext.
  - Java:
    o The build system and tools now also support Java versions newer than
      Java 11. This is known to work up to Java 20, at least. On the other
      hand, support for old versions of Java (Java 1.5 and GCJ) has been
      dropped.
  - Tcl: xgettext now supports the \x, \u, and \U escapes as defined in
    Tcl 8.6.

* Portability:
  - On systems with musl libc, the *gettext() functions in libc now work
    with MO files generated from PO files with an encoding other than UTF-8.
    To this effect, the msgfmt program now converts the messages to UTF-8
    encoding before storing them in a MO file.  You can prevent this by
    using the msgfmt --no-convert option.
  - On systems with musl libc, the *gettext() functions in libc now work
    with MO files generated from PO files with ISO C 99 <inttypes.h> format
    string directive macros.  To this effect, the msgfmt program pre-expands
    strings with such macros.  You can prevent this by using the msgfmt
    --no-redundancy option.

* xgettext:
  - The xgettext option '--sorted-output' is now deprecated.
  - xgettext input files of type PO that are not all ASCII and not UTF-8
    encoded are now handled correctly.

* The base Unicode standard is now updated to 15.0.0.

* Emacs PO mode:
  Fix an incompatibility with Emacs version 29 or newer.


Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../0001-init-env.in-do-not-add-C-CXX-parameters.patch          | 0
 .../0001-tests-autopoint-3-unset-MAKEFLAGS.patch                | 0
 .../gettext/{gettext-0.21.1 => gettext-0.22}/parallel.patch     | 0
 .../gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest          | 0
 .../{gettext-0.21.1 => gettext-0.22}/serial-tests-config.patch  | 0
 .../{gettext-0.21.1 => gettext-0.22}/use-pkgconfig.patch        | 0
 .../{gettext-minimal-0.21.1 => gettext-minimal-0.22}/COPYING    | 0
 .../Makefile.in.in                                              | 0
 .../aclocal/gettext.m4                                          | 0
 .../aclocal/host-cpu-c-abi.m4                                   | 0
 .../aclocal/iconv.m4                                            | 0
 .../aclocal/intlmacosx.m4                                       | 0
 .../aclocal/lib-ld.m4                                           | 0
 .../aclocal/lib-link.m4                                         | 0
 .../aclocal/lib-prefix.m4                                       | 0
 .../aclocal/nls.m4                                              | 0
 .../aclocal/po.m4                                               | 0
 .../aclocal/progtest.m4                                         | 0
 .../config.rpath                                                | 0
 .../remove-potcdate.sin                                         | 0
 ...-minimal-native_0.21.1.bb => gettext-minimal-native_0.22.bb} | 0
 .../recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} | 2 +-
 22 files changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/0001-init-env.in-do-not-add-C-CXX-parameters.patch (100%)
 rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/0001-tests-autopoint-3-unset-MAKEFLAGS.patch (100%)
 rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/parallel.patch (100%)
 rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest (100%)
 rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/serial-tests-config.patch (100%)
 rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/use-pkgconfig.patch (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/COPYING (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/Makefile.in.in (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/gettext.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/host-cpu-c-abi.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/iconv.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/intlmacosx.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/lib-ld.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/lib-link.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/lib-prefix.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/nls.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/po.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/progtest.m4 (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/config.rpath (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/remove-potcdate.sin (100%)
 rename meta/recipes-core/gettext/{gettext-minimal-native_0.21.1.bb => gettext-minimal-native_0.22.bb} (100%)
 rename meta/recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} (99%)

Comments

Richard Purdie June 27, 2023, 2:25 p.m. UTC | #1
On Tue, 2023-06-27 at 15:17 +0800, wangmy wrote:
> From: Wang Mingyu <wangmy@fujitsu.com>
> 
> Changelog:
> ===========
> * PO file format:
>   - When a #: line contains references to file names that contain spaces,
>     these file names are surrounded by Unicode characters U+2068 and U+2069.
>     This makes it possible to parse such references correctly.
> 
> * Improvements for maintainers:
>   - The AM_GNU_GETTEXT macro now defines two variables localedir_c and
>     localedir_c_make, that can be used in C code or in Makefiles,
>     respectively, for representing the value of the --localedir configure
>     option.
> 
> * Programming languages support:
>   - C, C++:
>     o xgettext now supports gettext-like functions that take wide strings
>       (of type 'const wchar_t *', 'const char16_t *', or 'const char32_t *')
>       as arguments.
>     o xgettext now recognizes numbers with digit separators, as defined by
>       ISO C 23, as tokens.
>     o xgettext and msgfmt now recognize the format string directive %b
>       (for binary integer output, as defined by ISO C 23) in format strings.
>     o xgettext and msgfmt now recognize the argument size specifiers
>       w8, w16, w32, w64, wf8, wf16, wf32, wf64 (as defined by ISO C 23)
>       in format strings.
>     o xgettext and msgfmt now recognize C++ format strings, as defined by
>       ISO C++ 20.  They are marked as 'c++-format' in POT and PO files.
>       A new example has been added, 'hello-c++20', that illustrates how
>       to use these format strings with gettext.
>   - Java:
>     o The build system and tools now also support Java versions newer than
>       Java 11. This is known to work up to Java 20, at least. On the other
>       hand, support for old versions of Java (Java 1.5 and GCJ) has been
>       dropped.
>   - Tcl: xgettext now supports the \x, \u, and \U escapes as defined in
>     Tcl 8.6.
> 
> * Portability:
>   - On systems with musl libc, the *gettext() functions in libc now work
>     with MO files generated from PO files with an encoding other than UTF-8.
>     To this effect, the msgfmt program now converts the messages to UTF-8
>     encoding before storing them in a MO file.  You can prevent this by
>     using the msgfmt --no-convert option.
>   - On systems with musl libc, the *gettext() functions in libc now work
>     with MO files generated from PO files with ISO C 99 <inttypes.h> format
>     string directive macros.  To this effect, the msgfmt program pre-expands
>     strings with such macros.  You can prevent this by using the msgfmt
>     --no-redundancy option.
> 
> * xgettext:
>   - The xgettext option '--sorted-output' is now deprecated.
>   - xgettext input files of type PO that are not all ASCII and not UTF-8
>     encoded are now handled correctly.
> 
> * The base Unicode standard is now updated to 15.0.0.
> 
> * Emacs PO mode:
>   Fix an incompatibility with Emacs version 29 or newer.
> 
> 
> Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> ---
>  .../0001-init-env.in-do-not-add-C-CXX-parameters.patch          | 0
>  .../0001-tests-autopoint-3-unset-MAKEFLAGS.patch                | 0
>  .../gettext/{gettext-0.21.1 => gettext-0.22}/parallel.patch     | 0
>  .../gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest          | 0
>  .../{gettext-0.21.1 => gettext-0.22}/serial-tests-config.patch  | 0
>  .../{gettext-0.21.1 => gettext-0.22}/use-pkgconfig.patch        | 0
>  .../{gettext-minimal-0.21.1 => gettext-minimal-0.22}/COPYING    | 0
>  .../Makefile.in.in                                              | 0
>  .../aclocal/gettext.m4                                          | 0
>  .../aclocal/host-cpu-c-abi.m4                                   | 0
>  .../aclocal/iconv.m4                                            | 0
>  .../aclocal/intlmacosx.m4                                       | 0
>  .../aclocal/lib-ld.m4                                           | 0
>  .../aclocal/lib-link.m4                                         | 0
>  .../aclocal/lib-prefix.m4                                       | 0
>  .../aclocal/nls.m4                                              | 0
>  .../aclocal/po.m4                                               | 0
>  .../aclocal/progtest.m4                                         | 0
>  .../config.rpath                                                | 0
>  .../remove-potcdate.sin                                         | 0
>  ...-minimal-native_0.21.1.bb => gettext-minimal-native_0.22.bb} | 0
>  .../recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} | 2 +-
>  22 files changed, 1 insertion(+), 1 deletion(-)
>  rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/0001-init-env.in-do-not-add-C-CXX-parameters.patch (100%)
>  rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/0001-tests-autopoint-3-unset-MAKEFLAGS.patch (100%)
>  rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/parallel.patch (100%)
>  rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest (100%)
>  rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/serial-tests-config.patch (100%)
>  rename meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/use-pkgconfig.patch (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/COPYING (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/Makefile.in.in (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/gettext.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/host-cpu-c-abi.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/iconv.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/intlmacosx.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/lib-ld.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/lib-link.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/lib-prefix.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/nls.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/po.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/aclocal/progtest.m4 (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/config.rpath (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-0.21.1 => gettext-minimal-0.22}/remove-potcdate.sin (100%)
>  rename meta/recipes-core/gettext/{gettext-minimal-native_0.21.1.bb => gettext-minimal-native_0.22.bb} (100%)
>  rename meta/recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} (99%)

When you upgraded this recipe did you check if there were changes to
any of the files in gettext-minimal in the new version? I'm a little
surprised none of the files change at all...

Cheers,

Richard
Mingyu Wang (Fujitsu) June 28, 2023, 8:53 a.m. UTC | #2
Sorry, I didn't notice that the files in the minimal directory need to be updated based on the source code. 
Please ignore this patch and I will investigate before considering whether to resubmit it.

  --
Best Regards
---------------------------------------------------
Wang Mingyu
Development Dept.I
Nanjing Fujitsu Nanda Software Tech. Co., Ltd.(FNST) No. 6 Wenzhu Road, Nanjing, 210012, China
TEL: +86+25-86630566-8568
COINS: 79988548
FAX: +86+25-83317685
MAIL: wangmy@fujitsu.com
http://www.fujitsu.com/cn/fnst/

> -----Original Message-----
> From: Richard Purdie <richard.purdie@linuxfoundation.org>
> Sent: Tuesday, June 27, 2023 10:25 PM
> To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>;
> openembedded-core@lists.openembedded.org
> Subject: Re: [PATCH] [OE-core] [PATCH] gettext: upgrade 0.21.1 -> 0.22
> 
> On Tue, 2023-06-27 at 15:17 +0800, wangmy wrote:
> > From: Wang Mingyu <wangmy@fujitsu.com>
> >
> > Changelog:
> > ===========
> > * PO file format:
> >   - When a #: line contains references to file names that contain spaces,
> >     these file names are surrounded by Unicode characters U+2068 and
> U+2069.
> >     This makes it possible to parse such references correctly.
> >
> > * Improvements for maintainers:
> >   - The AM_GNU_GETTEXT macro now defines two variables localedir_c and
> >     localedir_c_make, that can be used in C code or in Makefiles,
> >     respectively, for representing the value of the --localedir configure
> >     option.
> >
> > * Programming languages support:
> >   - C, C++:
> >     o xgettext now supports gettext-like functions that take wide strings
> >       (of type 'const wchar_t *', 'const char16_t *', or 'const char32_t *')
> >       as arguments.
> >     o xgettext now recognizes numbers with digit separators, as defined by
> >       ISO C 23, as tokens.
> >     o xgettext and msgfmt now recognize the format string directive %b
> >       (for binary integer output, as defined by ISO C 23) in format strings.
> >     o xgettext and msgfmt now recognize the argument size specifiers
> >       w8, w16, w32, w64, wf8, wf16, wf32, wf64 (as defined by ISO C 23)
> >       in format strings.
> >     o xgettext and msgfmt now recognize C++ format strings, as defined by
> >       ISO C++ 20.  They are marked as 'c++-format' in POT and PO files.
> >       A new example has been added, 'hello-c++20', that illustrates how
> >       to use these format strings with gettext.
> >   - Java:
> >     o The build system and tools now also support Java versions newer than
> >       Java 11. This is known to work up to Java 20, at least. On the other
> >       hand, support for old versions of Java (Java 1.5 and GCJ) has been
> >       dropped.
> >   - Tcl: xgettext now supports the \x, \u, and \U escapes as defined in
> >     Tcl 8.6.
> >
> > * Portability:
> >   - On systems with musl libc, the *gettext() functions in libc now work
> >     with MO files generated from PO files with an encoding other than
> UTF-8.
> >     To this effect, the msgfmt program now converts the messages to UTF-8
> >     encoding before storing them in a MO file.  You can prevent this by
> >     using the msgfmt --no-convert option.
> >   - On systems with musl libc, the *gettext() functions in libc now work
> >     with MO files generated from PO files with ISO C 99 <inttypes.h> format
> >     string directive macros.  To this effect, the msgfmt program
> pre-expands
> >     strings with such macros.  You can prevent this by using the msgfmt
> >     --no-redundancy option.
> >
> > * xgettext:
> >   - The xgettext option '--sorted-output' is now deprecated.
> >   - xgettext input files of type PO that are not all ASCII and not UTF-8
> >     encoded are now handled correctly.
> >
> > * The base Unicode standard is now updated to 15.0.0.
> >
> > * Emacs PO mode:
> >   Fix an incompatibility with Emacs version 29 or newer.
> >
> >
> > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > ---
> >  .../0001-init-env.in-do-not-add-C-CXX-parameters.patch          | 0
> >  .../0001-tests-autopoint-3-unset-MAKEFLAGS.patch                | 0
> >  .../gettext/{gettext-0.21.1 => gettext-0.22}/parallel.patch     | 0
> >  .../gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest          | 0
> >  .../{gettext-0.21.1 => gettext-0.22}/serial-tests-config.patch  | 0
> >  .../{gettext-0.21.1 => gettext-0.22}/use-pkgconfig.patch        | 0
> >  .../{gettext-minimal-0.21.1 => gettext-minimal-0.22}/COPYING    | 0
> >  .../Makefile.in.in                                              |
> 0
> >  .../aclocal/gettext.m4                                          |
> 0
> >  .../aclocal/host-cpu-c-abi.m4                                   | 0
> >  .../aclocal/iconv.m4                                            |
> 0
> >  .../aclocal/intlmacosx.m4                                       |
> 0
> >  .../aclocal/lib-ld.m4                                           | 0
> >  .../aclocal/lib-link.m4                                         | 0
> >  .../aclocal/lib-prefix.m4                                       | 0
> >  .../aclocal/nls.m4                                              |
> 0
> >  .../aclocal/po.m4
> | 0
> >  .../aclocal/progtest.m4                                         |
> 0
> >  .../config.rpath                                                |
> 0
> >  .../remove-potcdate.sin                                         |
> 0
> >  ...-minimal-native_0.21.1.bb => gettext-minimal-native_0.22.bb} | 0
> > .../recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} | 2 +-
> >  22 files changed, 1 insertion(+), 1 deletion(-)  rename
> > meta/recipes-core/gettext/{gettext-0.21.1 =>
> > gettext-0.22}/0001-init-env.in-do-not-add-C-CXX-parameters.patch
> > (100%)  rename meta/recipes-core/gettext/{gettext-0.21.1 =>
> > gettext-0.22}/0001-tests-autopoint-3-unset-MAKEFLAGS.patch (100%)
> > rename meta/recipes-core/gettext/{gettext-0.21.1 =>
> > gettext-0.22}/parallel.patch (100%)  rename
> > meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest
> > (100%)  rename meta/recipes-core/gettext/{gettext-0.21.1 =>
> > gettext-0.22}/serial-tests-config.patch (100%)  rename
> > meta/recipes-core/gettext/{gettext-0.21.1 =>
> > gettext-0.22}/use-pkgconfig.patch (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/COPYING (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/Makefile.in.in (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/gettext.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/host-cpu-c-abi.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/iconv.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/intlmacosx.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/lib-ld.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/lib-link.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/lib-prefix.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/nls.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/po.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/aclocal/progtest.m4 (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/config.rpath (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > gettext-minimal-0.22}/remove-potcdate.sin (100%)  rename
> > meta/recipes-core/gettext/{gettext-minimal-native_0.21.1.bb =>
> > gettext-minimal-native_0.22.bb} (100%)  rename
> > meta/recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} (99%)
> 
> When you upgraded this recipe did you check if there were changes to any of
> the files in gettext-minimal in the new version? I'm a little surprised none of the
> files change at all...
> 
> Cheers,
> 
> Richard
>
Alexander Kanavin July 6, 2023, 9:54 a.m. UTC | #3
I have reworked the gettext-minimal recipe to get the needed files
directly from upstream tarball:
https://git.yoctoproject.org/poky-contrib/commit/meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb?h=akanavin/package-version-updates&id=1f9b5e0b158f18d2e66337b1e902977fcd072d5a

You are welcome to cherry-pick this, and verify that it still does the
right thing with the updated gettext.

Alex

On Wed, 28 Jun 2023 at 10:53, wangmy <wangmy@fujitsu.com> wrote:
>
> Sorry, I didn't notice that the files in the minimal directory need to be updated based on the source code.
> Please ignore this patch and I will investigate before considering whether to resubmit it.
>
>   --
> Best Regards
> ---------------------------------------------------
> Wang Mingyu
> Development Dept.I
> Nanjing Fujitsu Nanda Software Tech. Co., Ltd.(FNST) No. 6 Wenzhu Road, Nanjing, 210012, China
> TEL: +86+25-86630566-8568
> COINS: 79988548
> FAX: +86+25-83317685
> MAIL: wangmy@fujitsu.com
> http://www.fujitsu.com/cn/fnst/
>
> > -----Original Message-----
> > From: Richard Purdie <richard.purdie@linuxfoundation.org>
> > Sent: Tuesday, June 27, 2023 10:25 PM
> > To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>;
> > openembedded-core@lists.openembedded.org
> > Subject: Re: [PATCH] [OE-core] [PATCH] gettext: upgrade 0.21.1 -> 0.22
> >
> > On Tue, 2023-06-27 at 15:17 +0800, wangmy wrote:
> > > From: Wang Mingyu <wangmy@fujitsu.com>
> > >
> > > Changelog:
> > > ===========
> > > * PO file format:
> > >   - When a #: line contains references to file names that contain spaces,
> > >     these file names are surrounded by Unicode characters U+2068 and
> > U+2069.
> > >     This makes it possible to parse such references correctly.
> > >
> > > * Improvements for maintainers:
> > >   - The AM_GNU_GETTEXT macro now defines two variables localedir_c and
> > >     localedir_c_make, that can be used in C code or in Makefiles,
> > >     respectively, for representing the value of the --localedir configure
> > >     option.
> > >
> > > * Programming languages support:
> > >   - C, C++:
> > >     o xgettext now supports gettext-like functions that take wide strings
> > >       (of type 'const wchar_t *', 'const char16_t *', or 'const char32_t *')
> > >       as arguments.
> > >     o xgettext now recognizes numbers with digit separators, as defined by
> > >       ISO C 23, as tokens.
> > >     o xgettext and msgfmt now recognize the format string directive %b
> > >       (for binary integer output, as defined by ISO C 23) in format strings.
> > >     o xgettext and msgfmt now recognize the argument size specifiers
> > >       w8, w16, w32, w64, wf8, wf16, wf32, wf64 (as defined by ISO C 23)
> > >       in format strings.
> > >     o xgettext and msgfmt now recognize C++ format strings, as defined by
> > >       ISO C++ 20.  They are marked as 'c++-format' in POT and PO files.
> > >       A new example has been added, 'hello-c++20', that illustrates how
> > >       to use these format strings with gettext.
> > >   - Java:
> > >     o The build system and tools now also support Java versions newer than
> > >       Java 11. This is known to work up to Java 20, at least. On the other
> > >       hand, support for old versions of Java (Java 1.5 and GCJ) has been
> > >       dropped.
> > >   - Tcl: xgettext now supports the \x, \u, and \U escapes as defined in
> > >     Tcl 8.6.
> > >
> > > * Portability:
> > >   - On systems with musl libc, the *gettext() functions in libc now work
> > >     with MO files generated from PO files with an encoding other than
> > UTF-8.
> > >     To this effect, the msgfmt program now converts the messages to UTF-8
> > >     encoding before storing them in a MO file.  You can prevent this by
> > >     using the msgfmt --no-convert option.
> > >   - On systems with musl libc, the *gettext() functions in libc now work
> > >     with MO files generated from PO files with ISO C 99 <inttypes.h> format
> > >     string directive macros.  To this effect, the msgfmt program
> > pre-expands
> > >     strings with such macros.  You can prevent this by using the msgfmt
> > >     --no-redundancy option.
> > >
> > > * xgettext:
> > >   - The xgettext option '--sorted-output' is now deprecated.
> > >   - xgettext input files of type PO that are not all ASCII and not UTF-8
> > >     encoded are now handled correctly.
> > >
> > > * The base Unicode standard is now updated to 15.0.0.
> > >
> > > * Emacs PO mode:
> > >   Fix an incompatibility with Emacs version 29 or newer.
> > >
> > >
> > > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > > ---
> > >  .../0001-init-env.in-do-not-add-C-CXX-parameters.patch          | 0
> > >  .../0001-tests-autopoint-3-unset-MAKEFLAGS.patch                | 0
> > >  .../gettext/{gettext-0.21.1 => gettext-0.22}/parallel.patch     | 0
> > >  .../gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest          | 0
> > >  .../{gettext-0.21.1 => gettext-0.22}/serial-tests-config.patch  | 0
> > >  .../{gettext-0.21.1 => gettext-0.22}/use-pkgconfig.patch        | 0
> > >  .../{gettext-minimal-0.21.1 => gettext-minimal-0.22}/COPYING    | 0
> > >  .../Makefile.in.in                                              |
> > 0
> > >  .../aclocal/gettext.m4                                          |
> > 0
> > >  .../aclocal/host-cpu-c-abi.m4                                   | 0
> > >  .../aclocal/iconv.m4                                            |
> > 0
> > >  .../aclocal/intlmacosx.m4                                       |
> > 0
> > >  .../aclocal/lib-ld.m4                                           | 0
> > >  .../aclocal/lib-link.m4                                         | 0
> > >  .../aclocal/lib-prefix.m4                                       | 0
> > >  .../aclocal/nls.m4                                              |
> > 0
> > >  .../aclocal/po.m4
> > | 0
> > >  .../aclocal/progtest.m4                                         |
> > 0
> > >  .../config.rpath                                                |
> > 0
> > >  .../remove-potcdate.sin                                         |
> > 0
> > >  ...-minimal-native_0.21.1.bb => gettext-minimal-native_0.22.bb} | 0
> > > .../recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} | 2 +-
> > >  22 files changed, 1 insertion(+), 1 deletion(-)  rename
> > > meta/recipes-core/gettext/{gettext-0.21.1 =>
> > > gettext-0.22}/0001-init-env.in-do-not-add-C-CXX-parameters.patch
> > > (100%)  rename meta/recipes-core/gettext/{gettext-0.21.1 =>
> > > gettext-0.22}/0001-tests-autopoint-3-unset-MAKEFLAGS.patch (100%)
> > > rename meta/recipes-core/gettext/{gettext-0.21.1 =>
> > > gettext-0.22}/parallel.patch (100%)  rename
> > > meta/recipes-core/gettext/{gettext-0.21.1 => gettext-0.22}/run-ptest
> > > (100%)  rename meta/recipes-core/gettext/{gettext-0.21.1 =>
> > > gettext-0.22}/serial-tests-config.patch (100%)  rename
> > > meta/recipes-core/gettext/{gettext-0.21.1 =>
> > > gettext-0.22}/use-pkgconfig.patch (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/COPYING (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/Makefile.in.in (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/gettext.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/host-cpu-c-abi.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/iconv.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/intlmacosx.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/lib-ld.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/lib-link.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/lib-prefix.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/nls.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/po.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/aclocal/progtest.m4 (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/config.rpath (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-0.21.1 =>
> > > gettext-minimal-0.22}/remove-potcdate.sin (100%)  rename
> > > meta/recipes-core/gettext/{gettext-minimal-native_0.21.1.bb =>
> > > gettext-minimal-native_0.22.bb} (100%)  rename
> > > meta/recipes-core/gettext/{gettext_0.21.1.bb => gettext_0.22.bb} (99%)
> >
> > When you upgraded this recipe did you check if there were changes to any of
> > the files in gettext-minimal in the new version? I'm a little surprised none of the
> > files change at all...
> >
> > Cheers,
> >
> > Richard
> >
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#183548): https://lists.openembedded.org/g/openembedded-core/message/183548
> Mute This Topic: https://lists.openembedded.org/mt/99805170/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-core/gettext/gettext-0.21.1/0001-init-env.in-do-not-add-C-CXX-parameters.patch b/meta/recipes-core/gettext/gettext-0.22/0001-init-env.in-do-not-add-C-CXX-parameters.patch
similarity index 100%
rename from meta/recipes-core/gettext/gettext-0.21.1/0001-init-env.in-do-not-add-C-CXX-parameters.patch
rename to meta/recipes-core/gettext/gettext-0.22/0001-init-env.in-do-not-add-C-CXX-parameters.patch
diff --git a/meta/recipes-core/gettext/gettext-0.21.1/0001-tests-autopoint-3-unset-MAKEFLAGS.patch b/meta/recipes-core/gettext/gettext-0.22/0001-tests-autopoint-3-unset-MAKEFLAGS.patch
similarity index 100%
rename from meta/recipes-core/gettext/gettext-0.21.1/0001-tests-autopoint-3-unset-MAKEFLAGS.patch
rename to meta/recipes-core/gettext/gettext-0.22/0001-tests-autopoint-3-unset-MAKEFLAGS.patch
diff --git a/meta/recipes-core/gettext/gettext-0.21.1/parallel.patch b/meta/recipes-core/gettext/gettext-0.22/parallel.patch
similarity index 100%
rename from meta/recipes-core/gettext/gettext-0.21.1/parallel.patch
rename to meta/recipes-core/gettext/gettext-0.22/parallel.patch
diff --git a/meta/recipes-core/gettext/gettext-0.21.1/run-ptest b/meta/recipes-core/gettext/gettext-0.22/run-ptest
similarity index 100%
rename from meta/recipes-core/gettext/gettext-0.21.1/run-ptest
rename to meta/recipes-core/gettext/gettext-0.22/run-ptest
diff --git a/meta/recipes-core/gettext/gettext-0.21.1/serial-tests-config.patch b/meta/recipes-core/gettext/gettext-0.22/serial-tests-config.patch
similarity index 100%
rename from meta/recipes-core/gettext/gettext-0.21.1/serial-tests-config.patch
rename to meta/recipes-core/gettext/gettext-0.22/serial-tests-config.patch
diff --git a/meta/recipes-core/gettext/gettext-0.21.1/use-pkgconfig.patch b/meta/recipes-core/gettext/gettext-0.22/use-pkgconfig.patch
similarity index 100%
rename from meta/recipes-core/gettext/gettext-0.21.1/use-pkgconfig.patch
rename to meta/recipes-core/gettext/gettext-0.22/use-pkgconfig.patch
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/COPYING b/meta/recipes-core/gettext/gettext-minimal-0.22/COPYING
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/COPYING
rename to meta/recipes-core/gettext/gettext-minimal-0.22/COPYING
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/Makefile.in.in b/meta/recipes-core/gettext/gettext-minimal-0.22/Makefile.in.in
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/Makefile.in.in
rename to meta/recipes-core/gettext/gettext-minimal-0.22/Makefile.in.in
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/gettext.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/gettext.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/gettext.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/gettext.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/host-cpu-c-abi.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/host-cpu-c-abi.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/host-cpu-c-abi.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/host-cpu-c-abi.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/iconv.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/iconv.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/iconv.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/iconv.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/intlmacosx.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/intlmacosx.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/intlmacosx.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/intlmacosx.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/lib-ld.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/lib-ld.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/lib-ld.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/lib-ld.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/lib-link.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/lib-link.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/lib-link.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/lib-link.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/lib-prefix.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/lib-prefix.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/lib-prefix.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/lib-prefix.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/nls.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/nls.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/nls.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/nls.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/po.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/po.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/po.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/po.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/progtest.m4 b/meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/progtest.m4
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/aclocal/progtest.m4
rename to meta/recipes-core/gettext/gettext-minimal-0.22/aclocal/progtest.m4
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/config.rpath b/meta/recipes-core/gettext/gettext-minimal-0.22/config.rpath
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/config.rpath
rename to meta/recipes-core/gettext/gettext-minimal-0.22/config.rpath
diff --git a/meta/recipes-core/gettext/gettext-minimal-0.21.1/remove-potcdate.sin b/meta/recipes-core/gettext/gettext-minimal-0.22/remove-potcdate.sin
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-0.21.1/remove-potcdate.sin
rename to meta/recipes-core/gettext/gettext-minimal-0.22/remove-potcdate.sin
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.22.bb
similarity index 100%
rename from meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb
rename to meta/recipes-core/gettext/gettext-minimal-native_0.22.bb
diff --git a/meta/recipes-core/gettext/gettext_0.21.1.bb b/meta/recipes-core/gettext/gettext_0.22.bb
similarity index 99%
rename from meta/recipes-core/gettext/gettext_0.21.1.bb
rename to meta/recipes-core/gettext/gettext_0.22.bb
index b80ea9276e..f633312231 100644
--- a/meta/recipes-core/gettext/gettext_0.21.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.22.bb
@@ -30,7 +30,7 @@  SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
            file://0001-tests-autopoint-3-unset-MAKEFLAGS.patch \
            file://0001-init-env.in-do-not-add-C-CXX-parameters.patch \
            "
-SRC_URI[sha256sum] = "e8c3650e1d8cee875c4f355642382c1df83058bd5a11ee8555c0cf276d646d45"
+SRC_URI[sha256sum] = "49f089be11b490170bbf09ed2f51e5f5177f55be4cc66504a5861820e0fb06ab"
 
 inherit autotools texinfo pkgconfig ptest