diff mbox series

libsoup: upgrade 3.2.2 -> 3.4.0

Message ID 1681117100-24726-4-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit c98d4d5cc7e1fd1f6d81e2bf2d7629a83bc9a63b
Headers show
Series libsoup: upgrade 3.2.2 -> 3.4.0 | expand

Commit Message

Mingyu Wang (Fujitsu) April 10, 2023, 8:58 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
* Fix possible crash in SoupContentSniffer
* Fix socket leak
* Add missing annotation to soup_header_g_string_append_param_quoted()
* Fix regression in 'SoupCookieJar' not handling valid Secure cookies
* Fix crash when skipping HTTP/1 response stream with chunked enconding
* Change Session to unqueue finished items earlier without an extra MainContext iteration
* Add 'SoupMessage::got-body-data' signal to monitor progress of reads
* Add 'soup_session_send_and_splice()' and 'soup_session_send_and_splice_async()' convenience APIs
* Add 'soup_message_set_force_http1()' and 'soup_message_get_force_http1()' APIs
* Change 'soup_cookie_copy()' to not retain default ports
* Ensure 'SoupServerMessage' socket is available in websocket handler
* Fix 'soup_message_new()' not erroring when URI has an empty host
* Fix thread-saftey issues in 'SoupConnectionAuth'
* Fix various connection leaks
* Fix the possibility of sending invalid empty 'Sec-WebSocket-Protocol' header
* Fix IO errors not being handled on 'CONNECT' messages
* Numerous improvements to cookies:
    * Add support for cookie prefixes ('__Secure-' and '__Host-')
    * Reject cookies with control characters in name or value
    * Reject 'SameSite=None' cookies without 'Secure'
    * Change 'soup_cookie_parse()' to be more strict about what is considered whitespace
    * Change default SameSite value to 'Lax'
    * Fix 'soup_cookie_equal()' with 'NULL' path

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../libsoup/{libsoup_3.2.2.bb => libsoup_3.4.0.bb}              | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-support/libsoup/{libsoup_3.2.2.bb => libsoup_3.4.0.bb} (94%)
diff mbox series

Patch

diff --git a/meta/recipes-support/libsoup/libsoup_3.2.2.bb b/meta/recipes-support/libsoup/libsoup_3.4.0.bb
similarity index 94%
rename from meta/recipes-support/libsoup/libsoup_3.2.2.bb
rename to meta/recipes-support/libsoup/libsoup_3.4.0.bb
index e16cd17705..d35e4f25c1 100644
--- a/meta/recipes-support/libsoup/libsoup_3.2.2.bb
+++ b/meta/recipes-support/libsoup/libsoup_3.4.0.bb
@@ -12,7 +12,7 @@  DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl nghttp2"
 SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
 
 SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
-SRC_URI[sha256sum] = "83673c685b910fb7d39f1f28eee5afbefb71c05798fc350ac3bf1b885e1efaa1"
+SRC_URI[sha256sum] = "23efff6ac70f2c1e873507dac52649eec032c1597a4ae951762ce3123789acc9"
 
 PROVIDES = "libsoup-3.0"
 CVE_PRODUCT = "libsoup"