diff mbox series

[v2] libpng: Enable NEON for aarch64 to enensure consistency with arm32.

Message ID 1673321469-27718-1-git-send-email-leimaohui@fujitsu.com
State New
Headers show
Series [v2] libpng: Enable NEON for aarch64 to enensure consistency with arm32. | expand

Commit Message

Maohui Lei (Fujitsu) Jan. 10, 2023, 3:31 a.m. UTC
NEON is enabled for aarch64 by default, so, to ensure consistency with
arm32, reference to libpng-1.6.38/configure, added
enable_hardware_optimizations option for aarch64.

Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
---
 meta/recipes-multimedia/libpng/libpng_1.6.39.bb | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Alexandre Belloni Jan. 11, 2023, 11:11 a.m. UTC | #1
v1 has already been applied and you didn't specify what changed since
then. Can you rebase?

On 10/01/2023 11:31:09+0800, leimaohui wrote:
> NEON is enabled for aarch64 by default, so, to ensure consistency with
> arm32, reference to libpng-1.6.38/configure, added
> enable_hardware_optimizations option for aarch64.
> 
> Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
> ---
>  meta/recipes-multimedia/libpng/libpng_1.6.39.bb | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
> index d9dcf37..a6c229f 100644
> --- a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
> +++ b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
> @@ -22,7 +22,9 @@ BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
>  inherit autotools binconfig-disabled pkgconfig
>  
>  # Work around missing symbols
> -EXTRA_OECONF:append:class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
> +ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
> +ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
> +EXTRA_OECONF += "${ARMNEON}"
>  
>  PACKAGES =+ "${PN}-tools"
>  
> -- 
> 1.8.3.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#175704): https://lists.openembedded.org/g/openembedded-core/message/175704
> Mute This Topic: https://lists.openembedded.org/mt/96170221/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alexandre Belloni Jan. 11, 2023, 11:12 a.m. UTC | #2
On 11/01/2023 12:11:49+0100, Alexandre Belloni wrote:
> v1 has already been applied and you didn't specify what changed since
> then. Can you rebase?

I'm mistaken, I'll handle this patch.

> 
> On 10/01/2023 11:31:09+0800, leimaohui wrote:
> > NEON is enabled for aarch64 by default, so, to ensure consistency with
> > arm32, reference to libpng-1.6.38/configure, added
> > enable_hardware_optimizations option for aarch64.
> > 
> > Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
> > ---
> >  meta/recipes-multimedia/libpng/libpng_1.6.39.bb | 4 +++-
> >  1 file changed, 3 insertions(+), 1 deletion(-)
> > 
> > diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
> > index d9dcf37..a6c229f 100644
> > --- a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
> > +++ b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
> > @@ -22,7 +22,9 @@ BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
> >  inherit autotools binconfig-disabled pkgconfig
> >  
> >  # Work around missing symbols
> > -EXTRA_OECONF:append:class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
> > +ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
> > +ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
> > +EXTRA_OECONF += "${ARMNEON}"
> >  
> >  PACKAGES =+ "${PN}-tools"
> >  
> > -- 
> > 1.8.3.1
> > 
> 
> > 
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#175704): https://lists.openembedded.org/g/openembedded-core/message/175704
> > Mute This Topic: https://lists.openembedded.org/mt/96170221/3617179
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> > 
> 
> 
> -- 
> Alexandre Belloni, co-owner and COO, Bootlin
> Embedded Linux and Kernel engineering
> https://bootlin.com
Michael Opdenacker March 15, 2023, 4:05 p.m. UTC | #3
Hi Lei,

On 10.01.23 at 04:31, leimaohui wrote:
> NEON is enabled for aarch64 by default, so, to ensure consistency with
> arm32, reference to libpng-1.6.38/configure, added
> enable_hardware_optimizations option for aarch64.
>
> Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>


Many thanks for your contributions to the project!

However, for future commits, we'd need you to do add one thing to your 
git configuration, so that your patches are given an "Author" field 
which matches your "Signed-off-by" information. See 
https://www.openembedded.org/wiki/How_to_submit_a_patch_to_OpenEmbedded#Fixing_your_From_identity 
for details.

Don't hesitate to send a patch test directly to me, if you wish.
Thanks in advance
Michael.
diff mbox series

Patch

diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
index d9dcf37..a6c229f 100644
--- a/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
+++ b/meta/recipes-multimedia/libpng/libpng_1.6.39.bb
@@ -22,7 +22,9 @@  BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
 inherit autotools binconfig-disabled pkgconfig
 
 # Work around missing symbols
-EXTRA_OECONF:append:class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
+ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}"
+ARMNEON:aarch64 = "--enable-hardware-optimizations=on"
+EXTRA_OECONF += "${ARMNEON}"
 
 PACKAGES =+ "${PN}-tools"