python3-pip: upgrade 22.0.2 -> 22.0.3

Message ID 1644316000-5853-2-git-send-email-wangmy@fujitsu.com
State Accepted, archived
Commit 72874df0a76869c21a28908597a6ea04213d1aeb
Headers show
Series python3-pip: upgrade 22.0.2 -> 22.0.3 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 8, 2022, 10:26 a.m. UTC
Changelog:
=========
Features
-------
Print the exception via rich.traceback, when running with --debug. (#10791)

Bug Fixes
---------
Only calculate topological installation order, for packages that are going to
be installed/upgraded.

This fixes an AssertionError that occured when determining installation order,
for a very specific combination of upgrading-already-installed-package + change
of dependencies + fetching some packages from a package index. This combination
was especially common in Read the Docs' builds. (#10851)

Use html.parser by default, instead of falling back to html5lib when
--use-deprecated=html5lib is not passed. (#10869)

Improved Documentation
----------------------
Clarify that using per-requirement overrides disables the usage of wheels. (#9674)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pip_22.0.2.bb => python3-pip_22.0.3.bb}     | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-devtools/python/{python3-pip_22.0.2.bb => python3-pip_22.0.3.bb} (89%)

Patch

diff --git a/meta/recipes-devtools/python/python3-pip_22.0.2.bb b/meta/recipes-devtools/python/python3-pip_22.0.3.bb
similarity index 89%
rename from meta/recipes-devtools/python/python3-pip_22.0.2.bb
rename to meta/recipes-devtools/python/python3-pip_22.0.3.bb
index e70a9556e3..889a6bf8ad 100644
--- a/meta/recipes-devtools/python/python3-pip_22.0.2.bb
+++ b/meta/recipes-devtools/python/python3-pip_22.0.3.bb
@@ -10,7 +10,7 @@  inherit pypi setuptools3
 
 SRC_URI += "file://0001-change-shebang-to-python3.patch"
 
-SRC_URI[sha256sum] = "27b4b70c34ec35f77947f777070d8331adbb1e444842e98e7150c288dc0caea4"
+SRC_URI[sha256sum] = "f29d589df8c8ab99c060e68ad294c4a9ed896624f6368c5349d70aa581b333d0"
 
 do_install:append() {
     # Install as pip3 and leave pip2 as default